summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb')
-rw-r--r--meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb b/meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb
index 54303fa0bd..c0c76ce1bd 100644
--- a/meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb
+++ b/meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb
@@ -3,19 +3,19 @@ HOMEPAGE = "https://github.com/jonmayergoogle/iotools"
LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
SRCREV = "8d928b3360246b8ead95b442ca3887ce8b8f942f"
-SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https;branch=master"
PV = "v1.6+git${SRCPV}"
-inherit obmc-phosphor-systemd
+SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
-FILES:${PN} = "${sbindir}"
+SYSTEMD_SERVICE:${PN} += "iotools-setup.service"
+
+inherit obmc-phosphor-systemd
do_compile() {
# CC is overridden in the Makefile, so override it harder in the invocation
oe_runmake CC="${CC}" DEBUG="${DEBUG_BUILD-0}" STATIC=0
}
-
# The "install" make target runs the binary to create links for subcommands.
# The links are excessive and this doesn't work for cross compiling.
do_install() {
@@ -23,4 +23,4 @@ do_install() {
install -m 0755 iotools ${D}${sbindir}
}
-SYSTEMD_SERVICE:${PN} += "iotools-setup.service"
+FILES:${PN} = "${sbindir}"