summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-devtools/python/pyphosphor_git.bb')
-rw-r--r--meta-phosphor/recipes-devtools/python/pyphosphor_git.bb34
1 files changed, 16 insertions, 18 deletions
diff --git a/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb b/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
index c2cfdb4cb9..039c718de2 100644
--- a/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
+++ b/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
@@ -1,25 +1,20 @@
SUMMARY = "Phosphor python library"
DESCRIPTION = "Phosphor python library."
HOMEPAGE = "http://github.com/openbmc/pyphosphor"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+SRCREV = "cb240aa1ed95799d2ea8bde951c6ed443839a7e0"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "git://github.com/openbmc/pyphosphor;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
inherit allarch
inherit setuptools3
inherit python3-dir
-PACKAGE_BEFORE_PN = " \
- ${PN}-ns \
- ${PN}-utils-ns \
- ${PN}-dbus-ns \
- ${PN}-wsgi-ns \
- ${PN}-wsgi-apps-ns \
- ${PN}-utils \
- ${PN}-dbus \
- "
-
RDEPENDS:${PN}-utils-ns += "${PN}-ns"
RDEPENDS:${PN}-dbus-ns += "${PN}-ns"
RDEPENDS:${PN}-utils += "${PN}-utils-ns"
@@ -44,12 +39,15 @@ FILES:${PN}-utils-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/utils/__init__.py*"
FILES:${PN}-dbus-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/dbuslib/__init__.py*"
FILES:${PN}-wsgi-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/wsgi/__init__.py*"
FILES:${PN}-wsgi-apps-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/wsgi/apps/__init__.py*"
-
FILES:${PN}-utils = "${PYTHON_SITEPACKAGES_DIR}/obmc/utils"
FILES:${PN}-dbus = "${PYTHON_SITEPACKAGES_DIR}/obmc/dbuslib"
-SRC_URI += "git://github.com/openbmc/pyphosphor;branch=master;protocol=https"
-
-SRCREV = "cb240aa1ed95799d2ea8bde951c6ed443839a7e0"
-
-S = "${WORKDIR}/git"
+PACKAGE_BEFORE_PN = " \
+ ${PN}-ns \
+ ${PN}-utils-ns \
+ ${PN}-dbus-ns \
+ ${PN}-wsgi-ns \
+ ${PN}-wsgi-apps-ns \
+ ${PN}-utils \
+ ${PN}-dbus \
+ "