summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb28
1 files changed, 11 insertions, 17 deletions
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb b/meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb
index d27f9d9861..4d237332eb 100644
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb
@@ -1,18 +1,8 @@
SUMMARY = "Phosphor Certificate Manager"
DESCRIPTION = "Manages client and server certificates"
HOMEPAGE = "https://github.com/openbmc/phosphor-certificate-manager"
-
-PR = "r1"
-PV = "0.1+git${SRCPV}"
-
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
-SRC_URI = "git://github.com/openbmc/phosphor-certificate-manager;branch=master;protocol=https"
-SRCREV = "b3dbfb37a6624153d5c27d87fc07d95e36bef352"
-
-inherit meson pkgconfig systemd
-
DEPENDS = " \
cli11 \
openssl \
@@ -21,18 +11,18 @@ DEPENDS = " \
sdbusplus \
sdeventplus \
"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMESON += "-Dtests=disabled"
-
-SYSTEMD_SERVICE:${PN} = "phosphor-certificate-manager@.service"
-
+SRCREV = "b3dbfb37a6624153d5c27d87fc07d95e36bef352"
PACKAGECONFIG ??= "bmcweb-cert nslcd-authority-cert"
PACKAGECONFIG[ibm-hypervisor-cert] = "-Dca-cert-extension=enabled,-Dca-cert-extension=disabled"
PACKAGECONFIG[bmcweb-cert] = "-Dconfig-bmcweb=enabled,-Dconfig-bmcweb=disabled"
PACKAGECONFIG[nslcd-authority-cert] = "-Dconfig-nslcd=enabled,-Dconfig-nslcd=disabled"
+PV = "0.1+git${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://github.com/openbmc/phosphor-certificate-manager;branch=master;protocol=https"
+S = "${WORKDIR}/git"
+SYSTEMD_SERVICE:${PN} = "phosphor-certificate-manager@.service"
SYSTEMD_SERVICE:${PN} = " \
phosphor-certificate-manager@.service \
${@bb.utils.contains('PACKAGECONFIG', 'ibm-hypervisor-cert', 'bmc-vmi-ca-manager.service', '', d)} \
@@ -40,4 +30,8 @@ SYSTEMD_SERVICE:${PN} = " \
${@bb.utils.contains('PACKAGECONFIG', 'bmcweb', 'phosphor-certificate-manager@bmcweb.service', '', d)} \
"
+inherit meson pkgconfig systemd
+
+EXTRA_OEMESON += "-Dtests=disabled"
+
FILES:${PN}:append = " ${systemd_system_unitdir}/* ${datadir}/dbus-1"