summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb32
1 files changed, 14 insertions, 18 deletions
diff --git a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
index eebffdd3e3..63e3f04307 100644
--- a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
@@ -1,16 +1,8 @@
SUMMARY = "Entity Manager"
DESCRIPTION = "Entity Manager provides d-bus configuration data \
and configures system sensors"
-
-SRC_URI = "git://github.com/openbmc/entity-manager.git;branch=master;protocol=https \
- file://blocklist.json \
- "
-SRCREV = "53f84ca26e949115d805d4f2834347df3238145e"
-PV = "0.1+git${SRCPV}"
-
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
-
DEPENDS = "boost \
dbus \
nlohmann-json \
@@ -18,21 +10,28 @@ DEPENDS = "boost \
valijson \
${PYTHON_PN}-jsonschema-native \
"
+SRCREV = "53f84ca26e949115d805d4f2834347df3238145e"
+PACKAGECONFIG ??= "ipmi-fru"
+PACKAGECONFIG[ipmi-fru] = "-Dfru-device=true, -Dfru-device=false, i2c-tools,"
+PV = "0.1+git${SRCPV}"
+
+SRC_URI = "git://github.com/openbmc/entity-manager.git;branch=master;protocol=https \
+ file://blocklist.json \
+ "
S = "${WORKDIR}/git"
+SYSTEMD_PACKAGES = "${PN} ${EXTRA_ENTITY_MANAGER_PACKAGES}"
+SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.EntityManager.service"
+SYSTEMD_SERVICE:fru-device = "xyz.openbmc_project.FruDevice.service"
+SYSTEMD_AUTO_ENABLE:fru-device_ibm-power-cpu = "disable"
+
inherit pkgconfig meson systemd python3native
EXTRA_OEMESON = "-Dtests=disabled"
-
-PACKAGECONFIG ??= "ipmi-fru"
-PACKAGECONFIG[ipmi-fru] = "-Dfru-device=true, -Dfru-device=false, i2c-tools,"
-
EXTRA_ENTITY_MANAGER_PACKAGES = " \
${@bb.utils.contains('PACKAGECONFIG', 'ipmi-fru', 'fru-device', '', d)} \
"
-PACKAGE_BEFORE_PN = "${EXTRA_ENTITY_MANAGER_PACKAGES}"
-
do_install:append() {
install -D ${WORKDIR}/blocklist.json ${D}${datadir}/${BPN}/blacklist.json
}
@@ -42,7 +41,4 @@ FILES:${PN} += " \
"
FILES:fru-device = "${bindir}/fru-device ${datadir}/${BPN}/blacklist.json"
-SYSTEMD_PACKAGES = "${PN} ${EXTRA_ENTITY_MANAGER_PACKAGES}"
-SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.EntityManager.service"
-SYSTEMD_SERVICE:fru-device = "xyz.openbmc_project.FruDevice.service"
-SYSTEMD_AUTO_ENABLE:fru-device_ibm-power-cpu = "disable"
+PACKAGE_BEFORE_PN = "${EXTRA_ENTITY_MANAGER_PACKAGES}"