summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb21
1 files changed, 11 insertions, 10 deletions
diff --git a/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb b/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb
index 6761c7ba35..ce66037577 100644
--- a/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb
@@ -1,13 +1,8 @@
SUMMARY = "Phosphor Time Manager daemon"
DESCRIPTION = "Daemon to cater to BMC and HOST time management"
HOMEPAGE = "http://github.com/openbmc/phosphor-time-manager"
-PR = "r1"
-
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-inherit meson pkgconfig python3native
-inherit obmc-phosphor-dbus-service
-
DEPENDS += "autoconf-archive-native"
DEPENDS += "phosphor-mapper"
DEPENDS += "systemd"
@@ -15,13 +10,19 @@ DEPENDS += "sdbusplus"
DEPENDS += "${PYTHON_PN}-sdbus++-native"
DEPENDS += "phosphor-logging"
DEPENDS += "phosphor-dbus-interfaces"
-RDEPENDS:${PN} += "phosphor-settings-manager"
-RDEPENDS:${PN} += "phosphor-network"
-RDEPENDS:${PN} += "phosphor-mapper"
-
-SRC_URI += "git://github.com/openbmc/phosphor-time-manager;branch=master;protocol=https"
SRCREV = "dc746c0b3bf8e635bcc45fb870e7c27013e122b6"
PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "git://github.com/openbmc/phosphor-time-manager;branch=master;protocol=https"
+
S = "${WORKDIR}/git"
+inherit meson pkgconfig python3native
+inherit obmc-phosphor-dbus-service
+
+RDEPENDS:${PN} += "phosphor-settings-manager"
+RDEPENDS:${PN} += "phosphor-network"
+RDEPENDS:${PN} += "phosphor-mapper"
+
DBUS_SERVICE:${PN} += "xyz.openbmc_project.Time.Manager.service"