summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb29
1 files changed, 14 insertions, 15 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
index 095aa24618..bcac236f86 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -1,24 +1,28 @@
SUMMARY = "Phosphor DBus Interfaces"
DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-inherit pkgconfig meson
-inherit obmc-phosphor-utils
-inherit phosphor-dbus-yaml
-inherit python3native
-
DEPENDS += " \
${PYTHON_PN}-sdbus++-native \
sdbusplus \
systemd \
"
+SRCREV = "a1a46a94405db4fc29d9ad695dee44e2214e4262"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces;branch=master;protocol=https"
-SRCREV = "a1a46a94405db4fc29d9ad695dee44e2214e4262"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig meson
+inherit obmc-phosphor-utils
+inherit phosphor-dbus-yaml
+inherit python3native
+
+# Markdown files are installed into /usr/share/phosphor-dbus-interfaces so
+# add them to the 'doc' subpackage.
+FILES:${PN}-doc += "${datadir}/${BPN}"
# Process OBMC_ORG_YAML_SUBDIRS to create Meson config options.
# ex. xyz/openbmc_project -> -Ddata_xyz_openbmc_project=true
@@ -29,14 +33,9 @@ def pdi_meson_config(d):
])
pdi_meson_config[vardeps] = "OBMC_ORG_YAML_SUBDIRS"
EXTRA_OEMESON += "${@pdi_meson_config(d)}"
-
# Remove all schemas by default regardless of the meson_options.txt config
do_write_config:append() {
for intf in $(grep "^option('data_" ${S}/meson_options.txt | sed "s,^.*\(data_[^']*\).*$,\1,"); do
sed -i "/^\[built-in options\]\$/a$intf = false" ${WORKDIR}/meson.cross
done
}
-
-# Markdown files are installed into /usr/share/phosphor-dbus-interfaces so
-# add them to the 'doc' subpackage.
-FILES:${PN}-doc += "${datadir}/${BPN}"