summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb31
1 files changed, 13 insertions, 18 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
index ca88023d9b..1ee9b86254 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
@@ -1,38 +1,33 @@
+# To add namespaces and blacklists to the mapper configuration,
+# create a native recipe in your layer, and add it to
+# PHOSPHOR_MAPPER_CONFIGS with a bbappend to this recipe.
+# Recipes should set one of the variables below.
+# Consult phosphor-mapper.bbclass for additional information.
SUMMARY = "Phosphor Mapper Configuration"
DESCRIPTION = "Meta-recipe, pulling in native recipes that wish to add \
configuration files to the native /usr/share/phosphor-mapper filesystem."
HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+DEPENDS += "${PHOSPHOR_MAPPER_CONFIGS}"
+PR = "r1"
inherit phosphor-mapper
inherit native
+do_install() {
+ install -d ${D}/${namespace_dir}
+ install -d ${D}/${interface_dir}
+ install -d ${D}/${serviceblacklist_dir}
+}
+
PHOSPHOR_MAPPER_CONFIGS = " \
phosphor-dbus-interfaces-mapper-config-native \
phosphor-legacy-namespace-mapper-config-native \
"
-
-DEPENDS += "${PHOSPHOR_MAPPER_CONFIGS}"
-
-# To add namespaces and blacklists to the mapper configuration,
-# create a native recipe in your layer, and add it to
-# PHOSPHOR_MAPPER_CONFIGS with a bbappend to this recipe.
-# Recipes should set one of the variables below.
-# Consult phosphor-mapper.bbclass for additional information.
-
# Add services to be monitored.
PHOSPHOR_MAPPER_SERVICE = ""
-
# Add interfaces to be monitored.
PHOSPHOR_MAPPER_INTERFACE = ""
-
# Blacklist services from being monitored.
PHOSPHOR_MAPPER_SERVICE_BLACKLIST = ""
-
-do_install() {
- install -d ${D}/${namespace_dir}
- install -d ${D}/${interface_dir}
- install -d ${D}/${serviceblacklist_dir}
-}