summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb38
1 files changed, 17 insertions, 21 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
index 4d49516a99..6925d71c1b 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
@@ -1,43 +1,43 @@
SUMMARY = "Phosphor DBUS Object Manager"
DESCRIPTION = "Phosphor DBUS object manager."
HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
-
-inherit meson pkgconfig
-inherit obmc-phosphor-dbus-service
-inherit obmc-phosphor-systemd
-inherit phosphor-mapperdir
-
DEPENDS += "systemd"
DEPENDS += "boost"
DEPENDS += "libtinyxml2"
DEPENDS += "sdbusplus"
DEPENDS += "phosphor-logging"
DEPENDS += "${PN}-config-native"
+SRCREV = "1e94e60b4fb6f6e1ebe42eeeeaf52a070ae11c30"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "git://github.com/openbmc/phosphor-objmgr;branch=master;protocol=https"
-DBUS_SERVICE:${PN} += "xyz.openbmc_project.ObjectMapper.service"
SYSTEMD_SERVICE:${PN} += " \
mapper-wait@.service \
mapper-subtree-remove@.service \
"
-SRC_URI += "git://github.com/openbmc/phosphor-objmgr;branch=master;protocol=https"
-
-SRCREV = "1e94e60b4fb6f6e1ebe42eeeeaf52a070ae11c30"
-
S = "${WORKDIR}/git"
+inherit meson pkgconfig
+inherit obmc-phosphor-dbus-service
+inherit obmc-phosphor-systemd
+inherit phosphor-mapperdir
+
EXTRA_OEMESON += "-Dtests=disabled"
+do_install[postfuncs] += "do_emit_env"
+
+PACKAGES_DYNAMIC += "^libmapper.*"
+
+FILES:${PN}:remove = "${libdir}/lib*.so.* ${libdir}/*"
+
python populate_packages:prepend () {
mapperlibdir = d.getVar("libdir", True)
do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True)
}
-PACKAGES_DYNAMIC += "^libmapper.*"
-FILES:${PN}:remove = "${libdir}/lib*.so.* ${libdir}/*"
-
# Construct a systemd environment file with mapper commandline
# from the native sysroot /usr/share/phosphor-mapper filesystem.
python do_emit_env() {
@@ -46,25 +46,21 @@ python do_emit_env() {
services = []
for s in os.listdir(path):
services.append('.'.join(s.split('-')))
-
path = d.getVar('STAGING_DIR_NATIVE', True) + \
d.getVar('interface_dir', True)
interfaces = []
for i in os.listdir(path):
interfaces.append('.'.join(i.split('-')))
-
path = d.getVar('STAGING_DIR_NATIVE', True) + \
d.getVar('serviceblacklist_dir', True)
service_blacklists = []
for x in os.listdir(path):
service_blacklists.append('.'.join(x.split('-')))
-
path = [d.getVar('D', True) + d.getVar('envfiledir', True)]
path.append('obmc')
path.append('mapper')
parent = os.path.join(*path[:-1])
path = os.path.join(*path)
-
if not os.path.exists(parent):
os.makedirs(parent)
with open(path, 'w+') as fd:
@@ -76,4 +72,4 @@ python do_emit_env() {
fd.write('\n')
}
-do_install[postfuncs] += "do_emit_env"
+DBUS_SERVICE:${PN} += "xyz.openbmc_project.ObjectMapper.service"