summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw.bb16
1 files changed, 7 insertions, 9 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw.bb
index aa0e80798b..84e4bf1a9b 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw.bb
@@ -1,24 +1,22 @@
SUMMARY = "Generate fan presence YAML from the MRW"
-PR = "r1"
LICENSE = "Apache-2.0"
-
-inherit allarch
-inherit phosphor-fan
-inherit mrw-xml
-
DEPENDS = "mrw-native mrw-perl-tools-native"
PROVIDES += "virtual/phosphor-fan-presence-config"
-
-FILES:${PN} += "${presence_datadir}/config.yaml"
+PR = "r1"
S = "${WORKDIR}"
+inherit allarch
+inherit phosphor-fan
+inherit mrw-xml
+
do_install() {
DEST=${D}${presence_datadir}
install -d ${DEST}
-
${bindir}/perl-native/perl \
${bindir}/gen_presence_yaml.pl \
-i ${STAGING_DIR_NATIVE}${mrw_datadir}/${MRW_XML} \
-o ${DEST}/config.yaml
}
+
+FILES:${PN} += "${presence_datadir}/config.yaml"