summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb15
1 files changed, 6 insertions, 9 deletions
diff --git a/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb b/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb
index a9123b1b4a..31a06284e2 100644
--- a/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb
+++ b/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb
@@ -1,31 +1,28 @@
SUMMARY = "Provides a host firmware image"
DESCRIPTION = "Use a bbappend to add the image files"
+LICENSE = "${HOSTFW_LICENSE}"
+LIC_FILES_CHKSUM = "${HOSTFW_LIC_FILES_CHKSUM}"
PR = "r1"
inherit allarch
inherit deploy
-HOSTFW_LICENSE ?= "Apache-2.0"
-HOSTFW_LIC_FILES_CHKSUM ?= "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-LICENSE = "${HOSTFW_LICENSE}"
-LIC_FILES_CHKSUM = "${HOSTFW_LIC_FILES_CHKSUM}"
-
do_compile() {
# The image directory can be used as the source to create a filesystem to
# add to the BMC image.
install -d ${B}/image
-
# Install an image-hostfw file in the update directory to be included in
# the code update tarball.
install -d ${B}/update
}
+addtask deploy before do_build after do_compile
+
+HOSTFW_LICENSE ?= "Apache-2.0"
+HOSTFW_LIC_FILES_CHKSUM ?= "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
do_deploy() {
install -d ${DEPLOYDIR}/hostfw/image
install -d ${DEPLOYDIR}/hostfw/update
cp -R --no-dereference --preserve=mode,links ${B}/image/ ${DEPLOYDIR}/hostfw/
cp -R --no-dereference --preserve=mode,links ${B}/update/ ${DEPLOYDIR}/hostfw/
}
-
-addtask deploy before do_build after do_compile