summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb24
1 files changed, 11 insertions, 13 deletions
diff --git a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
index ffe2f366ea..6cc31b4641 100644
--- a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
@@ -1,26 +1,24 @@
SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER"
DESCRIPTION = "A host control implementation suitable for OpenPOWER systems."
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-
-inherit skeleton-gdbus
-inherit obmc-phosphor-dbus-service
-inherit pkgconfig
-
PROVIDES += "virtual/obmc-host-ctl"
-RPROVIDES:${PN} += "virtual-obmc-host-ctl"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
SKELETON_DIR = "op-hostctl"
-
-FMT = "org.openbmc.control.Host@{0}.service"
-DBUS_SERVICE:${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
SYSTEMD_SERVICE:${PN} = " \
op-start-host@.service \
"
-
START_TMPL = "op-start-host@.service"
START_TGTFMT = "obmc-host-startmin@{1}.target"
START_INSTFMT = "op-start-host@{0}.service"
START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
-
SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
+
+inherit skeleton-gdbus
+inherit obmc-phosphor-dbus-service
+inherit pkgconfig
+
+RPROVIDES:${PN} += "virtual-obmc-host-ctl"
+
+FMT = "org.openbmc.control.Host@{0}.service"
+DBUS_SERVICE:${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"