summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb28
1 files changed, 12 insertions, 16 deletions
diff --git a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
index 9df4432fe5..9b2e41690a 100644
--- a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
+++ b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
@@ -1,30 +1,26 @@
DESCRIPTION = "Small image capable of booting a device. The kernel includes \
the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
first 'init' program more efficiently."
+LICENSE = "MIT"
+# Needed for the set_user_group functions to succeed
+DEPENDS += "shadow-native"
-# Init scripts
-INIT_PACKAGE = "obmc-phosphor-initfs"
-INIT_PACKAGE:df-phosphor-mmc = "phosphor-mmc-init"
+inherit core-image
+
+export IMAGE_BASENAME = "obmc-phosphor-initramfs"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"
PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} ${INIT_PACKAGE}"
+PACKAGE_INSTALL:remove = "shadow"
+# Init scripts
+INIT_PACKAGE = "obmc-phosphor-initfs"
+INIT_PACKAGE:df-phosphor-mmc = "phosphor-mmc-init"
# Do not pollute the initrd image with rootfs features
IMAGE_FEATURES = "read-only-rootfs"
-
-export IMAGE_BASENAME = "obmc-phosphor-initramfs"
IMAGE_LINGUAS = ""
-
-LICENSE = "MIT"
-
IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
-inherit core-image
-
IMAGE_ROOTFS_SIZE = "8192"
IMAGE_ROOTFS_EXTRA_SPACE = "0"
-
-# Needed for the set_user_group functions to succeed
-DEPENDS += "shadow-native"
-
-PACKAGE_INSTALL:remove = "shadow"
PACKAGE_EXCLUDE = "shadow"
-BAD_RECOMMENDATIONS += "busybox-syslog"