summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb b/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb
index 96c27da12b..c4d5bc8420 100644
--- a/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb
+++ b/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb
@@ -2,11 +2,20 @@ SUMMARY = "Phosphor OpenBMC pre-init scripts for mmc"
DESCRIPTION = "Phosphor OpenBMC filesystem mount implementation for mmc."
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
PR = "r1"
+SRC_URI += "file://mmc-init.sh"
+
+S = "${WORKDIR}"
+
inherit allarch
+do_install() {
+ install -m 0755 ${WORKDIR}/mmc-init.sh ${D}/init
+ install -d ${D}/dev
+ mknod -m 622 ${D}/dev/console c 5 1
+}
+
RDEPENDS:${PN} += " \
${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'} \
${VIRTUAL-RUNTIME_base-utils} \
@@ -18,13 +27,4 @@ RDEPENDS:${PN} += " \
udev \
"
-S = "${WORKDIR}"
-SRC_URI += "file://mmc-init.sh"
-
-do_install() {
- install -m 0755 ${WORKDIR}/mmc-init.sh ${D}/init
- install -d ${D}/dev
- mknod -m 622 ${D}/dev/console c 5 1
-}
-
FILES:${PN} += " /init /dev "