summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb17
1 files changed, 9 insertions, 8 deletions
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index 7665929b04..eb8e20a28d 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -1,19 +1,20 @@
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
DEPENDS = " \
- openssl \
- zlib \
boost \
- libpam \
- sdbusplus \
+ cli11 \
gtest \
- nlohmann-json \
+ libpam \
libtinyxml2 \
nghttp2 \
+ nlohmann-json \
+ openssl \
+ sdbusplus \
+ zlib \
${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \
${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \
"
-SRCREV = "478c5a57ac1143d689f3d3670092c2eb75e0f0c4"
+SRCREV = "c5bcf35f5b284e2df3b81202cee04996fd647cd9"
PV = "1.0+git${SRCPV}"
SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https"
@@ -32,13 +33,13 @@ PACKAGECONFIG ??= "mutual-tls-auth"
PACKAGECONFIG[insecure-redfish-expand]="-Dinsecure-enable-redfish-query=enabled"
PACKAGECONFIG[mutual-tls-auth]="-Dmutual-tls-auth=enabled,-Dmutual-tls-auth=disabled"
-MUTUAL_TLS_PARSING="username"
+MUTUAL_TLS_PARSING="CommonName"
EXTRA_OEMESON = " \
--buildtype=minsize \
-Dtests=${@bb.utils.contains('PTEST_ENABLED', '1', 'enabled', 'disabled', d)} \
${@bb.utils.contains('PACKAGECONFIG', 'mutual-tls-auth', \
- '-Dmutual-tls-common-name-parsing=' + d.getVar('MUTUAL_TLS_PARSING', True), \
+ '-Dmutual-tls-common-name-parsing-default=' + d.getVar('MUTUAL_TLS_PARSING', True), \
'', d)} \
"