summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/interfaces
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/interfaces')
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb59
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/rest-dbus_git.bb18
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/slpd-lite_git.bb17
3 files changed, 41 insertions, 53 deletions
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index b3ba0a1e00..da9d94541e 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -1,28 +1,5 @@
-inherit systemd
-inherit useradd
-
-USERADD_PACKAGES = "${PN}"
-
-# add a user called httpd for the server to assume
-USERADD_PARAM:${PN} = "-r -s /sbin/nologin bmcweb"
-GROUPADD_PARAM:${PN} = "web; redfish"
-
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
-
-SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https;nobranch=1"
-
-PV = "1.0+git${SRCPV}"
-SRCREV = "894744945e8f40a93fbcd6c100c92e0cf5b0ef67"
-
-S = "${WORKDIR}/git"
-
-inherit pkgconfig meson ptest
-
-SRC_URI += " \
- file://run-ptest \
-"
-
DEPENDS = " \
openssl \
zlib \
@@ -36,19 +13,20 @@ DEPENDS = " \
${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \
${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \
"
+SRCREV = "894744945e8f40a93fbcd6c100c92e0cf5b0ef67"
+PV = "1.0+git${SRCPV}"
-RDEPENDS:${PN} += " \
- jsnbd \
- phosphor-mapper \
+SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https;nobranch=1"
+SRC_URI += " \
+ file://run-ptest \
"
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/test
- cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/
-}
-
-FILES:${PN} += "${datadir}/** "
+S = "${WORKDIR}/git"
+SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket"
+inherit systemd
+inherit useradd
+inherit pkgconfig meson ptest
EXTRA_OEMESON = " \
--buildtype=minsize \
@@ -56,6 +34,21 @@ EXTRA_OEMESON = " \
-Dyocto-deps=enabled \
"
-SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket"
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/test
+ cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/
+}
+
+RDEPENDS:${PN} += " \
+ jsnbd \
+ phosphor-mapper \
+"
+FILES:${PN} += "${datadir}/** "
+
+USERADD_PACKAGES = "${PN}"
+# add a user called httpd for the server to assume
+USERADD_PARAM:${PN} = "-r -s /sbin/nologin bmcweb"
+
+GROUPADD_PARAM:${PN} = "web; redfish"
FULL_OPTIMIZATION = "-Os "
diff --git a/meta-phosphor/recipes-phosphor/interfaces/rest-dbus_git.bb b/meta-phosphor/recipes-phosphor/interfaces/rest-dbus_git.bb
index 27d873381a..c20621ec21 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/rest-dbus_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/rest-dbus_git.bb
@@ -1,10 +1,16 @@
SUMMARY = "Phosphor OpenBMC REST framework"
DESCRIPTION = "Phosphor OpenBMC REST to DBUS daemon."
HOMEPAGE = "http://github.com/openbmc/rest-dbus"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+SRCREV = "99d57f2698568be1bf989057f678ff5c053e7957"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "git://github.com/openbmc/rest-dbus.git;branch=master;protocol=https"
+
+SYSTEMD_SERVICE:${PN} += "rest-dbus.service rest-dbus.socket"
+S = "${WORKDIR}/git"
inherit allarch
inherit obmc-phosphor-systemd
@@ -17,11 +23,3 @@ RDEPENDS:${PN} += " \
python-xml \
pyphosphor-dbus \
"
-
-SYSTEMD_SERVICE:${PN} += "rest-dbus.service rest-dbus.socket"
-
-SRC_URI += "git://github.com/openbmc/rest-dbus.git;branch=master;protocol=https"
-
-SRCREV = "99d57f2698568be1bf989057f678ff5c053e7957"
-
-S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/interfaces/slpd-lite_git.bb b/meta-phosphor/recipes-phosphor/interfaces/slpd-lite_git.bb
index 7f77689d65..2233b0c6f0 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/slpd-lite_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/slpd-lite_git.bb
@@ -1,21 +1,18 @@
SUMMARY = "Lightweight SLP Server"
DESCRIPTION = "Lightweight Unicast-only SLP Server"
HOMEPAGE = "http://github.com/openbmc/slpd-lite"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-inherit autotools pkgconfig
-inherit obmc-phosphor-systemd
-
-SYSTEMD_SERVICE:${PN} += "slpd-lite.service"
-
DEPENDS += "systemd"
DEPENDS += "autoconf-archive-native"
+SRCREV = "ef078cd0d560b8c49061f0b855f0cb4450e69b3a"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
SRC_URI += "git://github.com/openbmc/slpd-lite;branch=master;protocol=https"
-SRCREV = "ef078cd0d560b8c49061f0b855f0cb4450e69b3a"
-
+SYSTEMD_SERVICE:${PN} += "slpd-lite.service"
S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-systemd