summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb35
1 files changed, 16 insertions, 19 deletions
diff --git a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
index ee839cc231..5a192a3053 100644
--- a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
@@ -2,18 +2,6 @@ SUMMARY = "Phosphor Inventory Manager"
DESCRIPTION = "Phosphor Inventory Manager is an inventory object \
lifecycle management application, suitable for use on a wide variety \
of OpenBMC platforms."
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-
-inherit meson \
- pkgconfig \
- python3native \
- phosphor-dbus-yaml \
- phosphor-inventory-manager \
- obmc-phosphor-dbus-service
-
-require phosphor-inventory-manager.inc
-
DEPENDS += " \
phosphor-inventory-manager-assettag \
phosphor-dbus-interfaces \
@@ -26,19 +14,28 @@ DEPENDS += " \
${PYTHON_PN}-mako-native \
nlohmann-json \
"
-
-OBMC_INVENTORY_PATH="${OBMC_DBUS_PATH_ROOT}/inventory"
-OBMC_INVENTORY_MGR_IFACE="${OBMC_DBUS_IFACE_ROOT}.Inventory.Manager"
-
-DBUS_SERVICE:${PN} = "${OBMC_INVENTORY_MGR_IFACE}.service"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[associations] = "-Dassociations=enabled, -Dassociations=disabled"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
S = "${WORKDIR}/git"
+inherit meson \
+ pkgconfig \
+ python3native \
+ phosphor-dbus-yaml \
+ phosphor-inventory-manager \
+ obmc-phosphor-dbus-service
+
EXTRA_OEMESON = " \
-Dtests=disabled \
-DYAML_PATH=${STAGING_DIR_HOST}${base_datadir} \
-DIFACES_PATH=${STAGING_DIR_TARGET}${yaml_dir} \
"
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[associations] = "-Dassociations=enabled, -Dassociations=disabled"
+require phosphor-inventory-manager.inc
+
+OBMC_INVENTORY_PATH = "${OBMC_DBUS_PATH_ROOT}/inventory"
+OBMC_INVENTORY_MGR_IFACE = "${OBMC_DBUS_IFACE_ROOT}.Inventory.Manager"
+DBUS_SERVICE:${PN} = "${OBMC_INVENTORY_MGR_IFACE}.service"