summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb16
1 files changed, 7 insertions, 9 deletions
diff --git a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
index 16790a3817..ee839cc231 100644
--- a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
@@ -5,7 +5,7 @@ of OpenBMC platforms."
PR = "r1"
PV = "1.0+git${SRCPV}"
-inherit autotools \
+inherit meson \
pkgconfig \
python3native \
phosphor-dbus-yaml \
@@ -20,11 +20,11 @@ DEPENDS += " \
phosphor-logging \
sdbusplus \
${PYTHON_PN}-sdbus++-native \
- autoconf-archive-native \
libcereal \
${PYTHON_PN}-native \
${PYTHON_PN}-pyyaml-native \
${PYTHON_PN}-mako-native \
+ nlohmann-json \
"
OBMC_INVENTORY_PATH="${OBMC_DBUS_PATH_ROOT}/inventory"
@@ -34,13 +34,11 @@ DBUS_SERVICE:${PN} = "${OBMC_INVENTORY_MGR_IFACE}.service"
S = "${WORKDIR}/git"
-EXTRA_OECONF = " \
- YAML_PATH=${STAGING_DIR_HOST}${base_datadir} \
- BUSNAME=${OBMC_INVENTORY_MGR_IFACE} \
- INVENTORY_ROOT=${OBMC_INVENTORY_PATH} \
- IFACE=${OBMC_INVENTORY_MGR_IFACE} \
- IFACES_PATH=${STAGING_DIR_TARGET}${yaml_dir} \
+EXTRA_OEMESON = " \
+ -Dtests=disabled \
+ -DYAML_PATH=${STAGING_DIR_HOST}${base_datadir} \
+ -DIFACES_PATH=${STAGING_DIR_TARGET}${yaml_dir} \
"
PACKAGECONFIG ??= ""
-PACKAGECONFIG[associations] = "--enable-associations, --disable-associations,nlohmann-json,"
+PACKAGECONFIG[associations] = "-Dassociations=enabled, -Dassociations=disabled"