summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb
index 2caf218cb9..60beb99db8 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-native.bb
@@ -1,22 +1,20 @@
SUMMARY = "FRU properties config for ipmi-fru-parser"
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit phosphor-ipmi-fru
-inherit native
+PROVIDES += "virtual/phosphor-ipmi-fru-properties"
+PR = "r1"
SRC_URI += "file://extra-properties.yaml"
-PROVIDES += "virtual/phosphor-ipmi-fru-properties"
-
S = "${WORKDIR}"
+inherit phosphor-ipmi-fru
+inherit native
+
do_install() {
# This recipe is supposed to create an output yaml file with
# FRU property values extracted from the MRW. This example recipe
# provides a sample output file.
-
DEST=${D}${properties_datadir}
install -d ${DEST}
install extra-properties.yaml ${DEST}