summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-inventory-example-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-inventory-example-native_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-inventory-example-native_git.bb13
1 files changed, 6 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-inventory-example-native_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-inventory-example-native_git.bb
index e205200052..0b6253aff8 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-inventory-example-native_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-inventory-example-native_git.bb
@@ -1,18 +1,17 @@
SUMMARY = "Sample inventory map for phosphor-ipmi-host"
-PR = "r1"
+PROVIDES += "virtual/phosphor-ipmi-fru-read-inventory"
PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+S = "${WORKDIR}/git"
inherit phosphor-ipmi-host
inherit native
-require phosphor-ipmi-host.inc
-
-PROVIDES += "virtual/phosphor-ipmi-fru-read-inventory"
-
-S = "${WORKDIR}/git"
-
do_install() {
DEST=${D}${config_datadir}
install -d ${DEST}
install scripts/fru-read-example.yaml ${DEST}/config.yaml
}
+
+require phosphor-ipmi-host.inc