summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb53
1 files changed, 24 insertions, 29 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
index b23efbea80..2a63b8737e 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
@@ -1,30 +1,45 @@
+# To add another RMCPP interface, add similar lines to the
+# following lines in a bbappend:
+#
+# ALT_RMCPP_IFACE = "eth1"
+# SYSTEMD_SERVICE:${PN} += " \
+# ${PN}@${ALT_RMCPP_IFACE}.service \
+# ${PN}@${ALT_RMCPP_IFACE}.socket \
+# "
+# Also, be sure to enable a corresponding entry in the channel
+# config file with the same 'name' as the interfaces above
+# Override the default phosphor-ipmi-config.bb with a bbappend
SUMMARY = "Phosphor Network IPMI Daemon"
DESCRIPTION = "Daemon to support IPMI protocol over network"
HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-inherit meson pkgconfig
-inherit systemd
-
DEPENDS += "cli11"
DEPENDS += "phosphor-mapper"
DEPENDS += "systemd"
DEPENDS += "phosphor-ipmi-host"
-
-RRECOMMENDS:${PN} = "pam-ipmi"
+SRCREV = "67aaec2e06ff9c2bfd5900b9f07834fca9d009f2"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid;branch=master;protocol=https"
-SRCREV = "67aaec2e06ff9c2bfd5900b9f07834fca9d009f2"
S = "${WORKDIR}/git"
+# install parameterized service and socket files
+SYSTEMD_SERVICE:${PN} = " \
+ ${PN}@${RMCPP_IFACE}.service \
+ ${PN}@${RMCPP_IFACE}.socket \
+ "
+
+inherit meson pkgconfig
+inherit systemd
EXTRA_OEMESON = " \
-Dtests=disabled \
"
+RRECOMMENDS:${PN} = "pam-ipmi"
+
FILES:${PN} += " \
${systemd_system_unitdir}/${PN}@.service \
${systemd_system_unitdir}/${PN}@.socket \
@@ -33,23 +48,3 @@ FILES:${PN} += " \
# If RMCPP_IFACE is not set by bbappend, set it to default
DEFAULT_RMCPP_IFACE = "eth0"
RMCPP_IFACE ?= "${DEFAULT_RMCPP_IFACE}"
-
-# install parameterized service and socket files
-SYSTEMD_SERVICE:${PN} = " \
- ${PN}@${RMCPP_IFACE}.service \
- ${PN}@${RMCPP_IFACE}.socket \
- "
-
-# To add another RMCPP interface, add similar lines to the
-# following lines in a bbappend:
-#
-# ALT_RMCPP_IFACE = "eth1"
-# SYSTEMD_SERVICE:${PN} += " \
-# ${PN}@${ALT_RMCPP_IFACE}.service \
-# ${PN}@${ALT_RMCPP_IFACE}.socket \
-# "
-
-# Also, be sure to enable a corresponding entry in the channel
-# config file with the same 'name' as the interfaces above
-# Override the default phosphor-ipmi-config.bb with a bbappend
-