summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb36
1 files changed, 16 insertions, 20 deletions
diff --git a/meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb b/meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb
index 8183d08afa..909c486c08 100644
--- a/meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb
+++ b/meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb
@@ -1,38 +1,34 @@
SUMMARY = "MCTP stack"
DESCRIPTION = "MCTP library implementing the MCTP base specification"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-
-inherit systemd
-inherit autotools pkgconfig
-
HOMEPAGE = "https://github.com/openbmc/libmctp"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=0d30807bb7a4f16d36e96b78f9ed8fae"
-SRC_URI = "git://github.com/openbmc/libmctp;branch=master;protocol=https \
- file://default"
-SRCREV = "fe763e9820668b90c22b0101994ac6bd6cd41c09"
-
DEPENDS += "autoconf-archive-native \
systemd \
"
-
-SYSTEMD_SERVICE:${PN} = "mctp-demux.service \
- mctp-demux.socket \
- "
-
+SRCREV = "fe763e9820668b90c22b0101994ac6bd6cd41c09"
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} pcap"
PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, \
--without-systemdsystemunitdir,systemd"
-
PACKAGECONFIG[astlpc-raw-kcs] = "--enable-astlpc-raw-kcs,--disable-astlpc-raw-kcs,udev,udev"
PACKAGECONFIG[pcap] = "--enable-capture,--disable-capture,libpcap,"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
-CONFFILES:${PN} = "${sysconfdir}/default/mctp"
+SRC_URI = "git://github.com/openbmc/libmctp;branch=master;protocol=https \
+ file://default"
+
+SYSTEMD_SERVICE:${PN} = "mctp-demux.service \
+ mctp-demux.socket \
+ "
+S = "${WORKDIR}/git"
+
+inherit systemd
+inherit autotools pkgconfig
do_install:append() {
- install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/mctp
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/mctp
}
-S = "${WORKDIR}/git"
+CONFFILES:${PN} = "${sysconfdir}/default/mctp"