summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
new file mode 100644
index 0000000000..f76d202e16
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Generated callout information for phosphor-logging"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-logging
+
+SRC_URI += "file://callouts.yaml"
+
+PROVIDES += "virtual/phosphor-logging-callouts"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${callouts_datadir}
+ install -d ${DEST}
+ install callouts.yaml ${DEST}
+}