summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/pldm/pldm_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm_git.bb31
1 files changed, 12 insertions, 19 deletions
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index 4c9cbc983a..bf67245bca 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -1,49 +1,42 @@
SUMMARY = "PLDM Stack"
DESCRIPTION = "Implementation of the PLDM specifications"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-
-inherit meson pkgconfig
-inherit systemd
-
-require pldm.inc
-
DEPENDS += "function2"
DEPENDS += "systemd"
DEPENDS += "sdeventplus"
DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "nlohmann-json"
DEPENDS += "cli11"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
S = "${WORKDIR}/git"
-
SYSTEMD_SERVICE:${PN} += "pldmd.service"
SYSTEMD_SERVICE:${PN} += "pldmSoftPowerOff.service"
+inherit meson pkgconfig
+inherit systemd
+
EXTRA_OEMESON = " \
-Dtests=disabled \
-Doem-ibm=disabled \
"
+pkg_prerm:${PN} () {
+ LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
+ rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
+ rm $LINK
+}
# Install pldmSoftPowerOff.service in correct targets
pkg_postinst:${PN} () {
-
mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants
LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
TARGET="../pldmSoftPowerOff.service"
ln -s $TARGET $LINK
-
mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants
LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
TARGET="../pldmSoftPowerOff.service"
ln -s $TARGET $LINK
}
-pkg_prerm:${PN} () {
-
- LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
- rm $LINK
-
- LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
- rm $LINK
-}
+require pldm.inc