summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb25
1 files changed, 10 insertions, 15 deletions
diff --git a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
index 6b773dff12..d9da9779b7 100644
--- a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
+++ b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
@@ -1,6 +1,3 @@
-SUMMARY = "Journal IPMI SEL Logger"
-DESCRIPTION = "Utility to write IPMI SEL records to the journal"
-
# SEL Logger has the ability to monitor and automatically log SEL records for
# various types of events, but this is disabled by default. The following
# flags can be set in a .bbappend to enable specific types of event
@@ -8,26 +5,16 @@ DESCRIPTION = "Utility to write IPMI SEL records to the journal"
#
# SEL_LOGGER_MONITOR_THRESHOLD_EVENTS:
# Monitors and logs SEL records for threshold sensor events
-
-inherit pkgconfig meson systemd
-S = "${WORKDIR}/git"
-
+SUMMARY = "Journal IPMI SEL Logger"
+DESCRIPTION = "Utility to write IPMI SEL records to the journal"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
DEPENDS += " \
boost \
sdbusplus \
systemd \
"
-
-SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=https;branch=master"
SRCREV = "628058fadb9d4c35dbe2c9636f3e6e93767e9526"
-
-PV = "0.1+git${SRCPV}"
-
-SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.Logging.IPMI.service"
-
PACKAGECONFIG ??= ""
PACKAGECONFIG[log-threshold] = "-Dlog-threshold=true,-Dlog-threshold=false,"
PACKAGECONFIG[log-pulse] = "-Dlog-pulse=true,-Dlog-pulse=false,"
@@ -35,3 +22,11 @@ PACKAGECONFIG[log-watchdog] = "-Dlog-watchdog=true,-Dlog-watchdog=false,"
PACKAGECONFIG[log-alarm] = "-Dlog-alarm=true,-Dlog-alarm=false,"
PACKAGECONFIG[send-to-logger] = "-Dsend-to-logger=true,-Dsend-to-logger=false,phosphor-logging"
PACKAGECONFIG[clears-sel] = "-Dclears-sel=true,-Dclears-sel=false"
+PV = "0.1+git${SRCPV}"
+
+SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.Logging.IPMI.service"
+
+inherit pkgconfig meson systemd