summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb50
1 files changed, 20 insertions, 30 deletions
diff --git a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
index 160abb2d99..516fc815f4 100644
--- a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
+++ b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
@@ -1,23 +1,7 @@
SUMMARY = "OpenBMC hwmon poller"
DESCRIPTION = "OpenBMC hwmon poller."
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
-
-inherit pkgconfig meson
-inherit obmc-phosphor-systemd
-
-PACKAGECONFIG ??= ""
-# Meson configure option to enable/disable max31785-msl
-PACKAGECONFIG[max31785-msl] = "-Denable-max31785-msl=true, -Denable-max31785-msl=false"
-
-PACKAGE_BEFORE_PN = "max31785-msl"
-SYSTEMD_PACKAGES = "${PN} max31785-msl"
-
-SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.Hwmon@.service"
-SYSTEMD_SERVICE:max31785-msl = "${@bb.utils.contains('PACKAGECONFIG', 'max31785-msl', 'phosphor-max31785-msl@.service', '', d)}"
-
DEPENDS += " \
sdbusplus \
sdeventplus \
@@ -27,27 +11,37 @@ DEPENDS += " \
gpioplus \
cli11 \
"
+SRCREV = "5e5259bf6710f22d3b78667098e56fa0e4895160"
+PACKAGECONFIG ??= ""
+# Meson configure option to enable/disable max31785-msl
+PACKAGECONFIG[max31785-msl] = "-Denable-max31785-msl=true, -Denable-max31785-msl=false"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "git://github.com/openbmc/phosphor-hwmon;branch=master;protocol=https"
+
+SYSTEMD_PACKAGES = "${PN} max31785-msl"
+SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.Hwmon@.service"
+SYSTEMD_SERVICE:max31785-msl = "${@bb.utils.contains('PACKAGECONFIG', 'max31785-msl', 'phosphor-max31785-msl@.service', '', d)}"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig meson
+inherit obmc-phosphor-systemd
EXTRA_OEMESON:append = " -Dtests=disabled"
-FILES:${PN} += "${base_libdir}/systemd/system/xyz.openbmc_project.Hwmon@.service"
RDEPENDS:${PN} += "\
bash \
"
+RDEPENDS:max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools bash"
RRECOMMENDS:${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
+FILES:${PN} += "${base_libdir}/systemd/system/xyz.openbmc_project.Hwmon@.service"
FILES:max31785-msl = "\
${base_libdir}/systemd/system/phosphor-max31785-msl@.service \
${bindir}/max31785-msl \
"
-RDEPENDS:max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools bash"
-
-SRC_URI += "git://github.com/openbmc/phosphor-hwmon;branch=master;protocol=https"
-
-SRCREV = "5e5259bf6710f22d3b78667098e56fa0e4895160"
-
-S = "${WORKDIR}/git"
# The following postinstall script iterate over hwmon env files:
# 1. It adds HW_SENSOR_ID value if not set. The value being calculated
@@ -56,7 +50,6 @@ S = "${WORKDIR}/git"
pkg_postinst:${PN}() {
hwmon_dir="$D/etc/default/obmc/hwmon"
dbus_dir="$D/${datadir}/dbus-1/system.d"
-
if [ -n "$D" -a -d "${hwmon_dir}" ]; then
# Remove existing links and replace with actual copy of the file to prevent
# HW_SENSOR_ID variable override for different sensors' instances.
@@ -65,22 +58,17 @@ pkg_postinst:${PN}() {
rm -f "${f}"
cp "${path}" "${f}"
done
-
find "${hwmon_dir}" -type f -name \*.conf | while read f; do
path="/${f##${hwmon_dir}/}"
path="${path%.conf}"
sensor_id="$(printf "%s" "${path}" | sha256sum | cut -d\ -f1)"
acl_file="${dbus_dir}/xyz.openbmc_project.Hwmon-${sensor_id}.conf"
-
egrep -q '^HW_SENSOR_ID\s*=' "${f}" ||
printf "\n# Sensor id for %s\nHW_SENSOR_ID = \"%s\"\n" "${path}" "${sensor_id}" >> "${f}"
-
# Extract HW_SENSOR_ID that could be either quoted or unquoted string.
sensor_id="$(sed -n 's,^HW_SENSOR_ID\s*=\s*"\?\(.[^" ]\+\)\s*"\?,\1,p' "${f}")"
-
[ ! -f "${acl_file}" ] || continue
path_s="$(echo "${path}" | sed 's,\-\-,\\-\\-,g')"
-
cat <<EOF>"${acl_file}"
<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
@@ -95,3 +83,5 @@ EOF
done
fi
}
+
+PACKAGE_BEFORE_PN = "max31785-msl"