summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/settings/phosphor-settings-read-settings-mrw-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/settings/phosphor-settings-read-settings-mrw-native.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/settings/phosphor-settings-read-settings-mrw-native.bb16
1 files changed, 6 insertions, 10 deletions
diff --git a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-read-settings-mrw-native.bb b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-read-settings-mrw-native.bb
index a67d6819dc..9122522ba5 100644
--- a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-read-settings-mrw-native.bb
+++ b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-read-settings-mrw-native.bb
@@ -1,31 +1,25 @@
# Generates MRW settings override yaml for phosphor-settings-manager
# The default YAML file, mrw-override-settings.yaml, is empty, therefore no
# settings will be overwritten. To override, modify mrw-override-settings.yaml.
-
SUMMARY = "Generates MRW settings override YAML for phosphor-settings-manager."
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit phosphor-settings-manager
-inherit mrw-xml
-inherit native
-
DEPENDS += "mrw-native mrw-perl-tools-native"
+PR = "r1"
SRC_URI += "file://mrw-override-settings.yaml"
S = "${WORKDIR}"
-MRW_EXPRESSION_VARS ?= ""
+inherit phosphor-settings-manager
+inherit mrw-xml
+inherit native
do_install() {
DEST=${D}${config_datadir}
install -D mrw-override-settings.yaml ${DEST}/mrw-override-settings.yaml
-
SETTINGS=${D}${settings_datadir}
install -d ${SETTINGS}
-
# gen_settings.pl replaces any MRW variables with their value
${bindir}/perl-native/perl \
${bindir}/gen_settings.pl \
@@ -35,3 +29,5 @@ do_install() {
${MRW_EXPRESSION_VARS} \
-f
}
+
+MRW_EXPRESSION_VARS ?= ""