summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/storage/estoraged.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/storage/estoraged.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/storage/estoraged.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta-phosphor/recipes-phosphor/storage/estoraged.bb b/meta-phosphor/recipes-phosphor/storage/estoraged.bb
index 92c92d7a05..18dd54758f 100644
--- a/meta-phosphor/recipes-phosphor/storage/estoraged.bb
+++ b/meta-phosphor/recipes-phosphor/storage/estoraged.bb
@@ -1,11 +1,7 @@
SUMMARY = "Encrypted storage management daemon"
DESCRIPTION = "Provides a D-Bus interface to manage an encrypted storage device"
-PR = "r1"
-PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-inherit meson pkgconfig systemd
-
DEPENDS += "systemd"
DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "cryptsetup"
@@ -13,14 +9,18 @@ DEPENDS += "openssl"
DEPENDS += "phosphor-logging"
DEPENDS += "sdbusplus"
DEPENDS += "stdplus"
+SRCREV = "da5e96a7e322d4a6bfef21438266114e55682161"
+PV = "0.1+git${SRCPV}"
+PR = "r1"
-RDEPENDS:${PN} += "e2fsprogs"
-
-EXTRA_OEMESON = "-Dtests=disabled"
-
-S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/estoraged.git;branch=master;protocol=https"
-SRCREV = "da5e96a7e322d4a6bfef21438266114e55682161"
+S = "${WORKDIR}/git"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.eStoraged.service"
+
+inherit meson pkgconfig systemd
+
+EXTRA_OEMESON = "-Dtests=disabled"
+
+RDEPENDS:${PN} += "e2fsprogs"