summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/storage/estoraged_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/storage/estoraged_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/storage/estoraged_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/storage/estoraged_git.bb b/meta-phosphor/recipes-phosphor/storage/estoraged_git.bb
new file mode 100644
index 0000000000..36f30dc575
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/storage/estoraged_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Encrypted storage management daemon"
+DESCRIPTION = "Provides a D-Bus interface to manage an encrypted storage device"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+DEPENDS += "systemd"
+DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "cryptsetup"
+DEPENDS += "openssl"
+DEPENDS += "phosphor-logging"
+DEPENDS += "sdbusplus"
+DEPENDS += "stdplus"
+SRCREV = "2443a0217d6ffe4cec3226992a49b45d37bbb53d"
+PV = "0.1+git${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://github.com/openbmc/estoraged.git;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.eStoraged.service"
+
+inherit meson pkgconfig systemd
+
+EXTRA_OEMESON = "-Dtests=disabled"
+
+RDEPENDS:${PN} += "e2fsprogs"