summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/video/fbterm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/video/fbterm_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/video/fbterm_git.bb22
1 files changed, 9 insertions, 13 deletions
diff --git a/meta-phosphor/recipes-phosphor/video/fbterm_git.bb b/meta-phosphor/recipes-phosphor/video/fbterm_git.bb
index 568bbc640b..9024b6404e 100644
--- a/meta-phosphor/recipes-phosphor/video/fbterm_git.bb
+++ b/meta-phosphor/recipes-phosphor/video/fbterm_git.bb
@@ -1,29 +1,25 @@
HOMEPAGE = "https://github.com/jk-ozlabs/fbterm"
LICENSE = "GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=d8e20eece214df8ef953ed5857862150"
+DEPENDS += "freetype"
+DEPENDS += "fontconfig"
+SRCREV = "c15430560aeb82a27358cc320af4a29e1296e6c1"
+PV = "1.7+git${SRCPV}"
+PR = "r1"
SRC_URI += "git://github.com/jk-ozlabs/fbterm.git;nobranch=1;protocol=https"
SRC_URI += "file://fb.modes"
-PR = "r1"
-
-LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=d8e20eece214df8ef953ed5857862150"
-DEPENDS += "freetype"
-DEPENDS += "fontconfig"
+S = "${WORKDIR}/git"
+SYSTEMD_SERVICE:${PN} += "fbterm.service"
+SYSTEMD_ENVIRONMENT_FILE:${PN} += "fbterm"
inherit autotools
inherit pkgconfig
inherit obmc-phosphor-systemd
-SRCREV = "c15430560aeb82a27358cc320af4a29e1296e6c1"
-PV = "1.7+git${SRCPV}"
-
-S = "${WORKDIR}/git"
-
do_install() {
oe_runmake 'DESTDIR=${D}' install-exec
install -d ${D}${sysconfdir}/
install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}/
}
-
-SYSTEMD_SERVICE:${PN} += "fbterm.service"
-SYSTEMD_ENVIRONMENT_FILE:${PN} += "fbterm"