summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb24
1 files changed, 10 insertions, 14 deletions
diff --git a/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb b/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb
index 387be0f443..f2c39df4b0 100644
--- a/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb
+++ b/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb
@@ -1,29 +1,25 @@
HOMEPAGE = "https://github.com/jk-ozlabs/uart-render-controller"
LICENSE = "GPL-2.0-or-later"
-
-SRC_URI += "git://github.com/jk-ozlabs/uart-render-controller;branch=master;protocol=https"
-SRC_URI += "file://uart-render-controller.service"
-
-PR = "r1"
-
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
-
-inherit autotools
-inherit pkgconfig
-inherit systemd
-
DEPENDS += "autoconf-archive-native"
DEPENDS += "systemd"
-RDEPENDS:${PN} += "fbterm"
-
SRCREV = "08e854a6c425011d029e4e02241afee5060f15eb"
PV = "0.1+git${SRCPV}"
+PR = "r1"
-S = "${WORKDIR}/git"
+SRC_URI += "git://github.com/jk-ozlabs/uart-render-controller;branch=master;protocol=https"
+SRC_URI += "file://uart-render-controller.service"
+S = "${WORKDIR}/git"
SYSTEMD_SERVICE:${PN} += "uart-render-controller.service"
+inherit autotools
+inherit pkgconfig
+inherit systemd
+
do_install:append() {
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/uart-render-controller.service ${D}${systemd_system_unitdir}/
}
+
+RDEPENDS:${PN} += "fbterm"