summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb16
1 files changed, 7 insertions, 9 deletions
diff --git a/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb b/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
index 6941ae8b33..b997b99750 100644
--- a/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
+++ b/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
@@ -1,20 +1,18 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+DEPENDS:prepend = "nodejs-native "
+SRCREV = "e16bb5c35893591eab048ae4ef646a9e5e2f7e94"
+PV = "1.0+git${SRCPV}"
# This recipe requires online access to build, as it uses NPM for dependency
# management and resolution.
PR = "r1"
-PV = "1.0+git${SRCPV}"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI = "git://github.com/openbmc/phosphor-webui.git;branch=master;protocol=https"
-SRCREV = "e16bb5c35893591eab048ae4ef646a9e5e2f7e94"
-S = "${WORKDIR}/git"
-DEPENDS:prepend = "nodejs-native "
+S = "${WORKDIR}/git"
inherit allarch
-FILES:${PN} += "${datadir}/www/*"
-
do_compile () {
bbwarn "phosphor-webui is deprecated and has been replaced with webui-vue"
cd ${S}
@@ -22,7 +20,6 @@ do_compile () {
npm --loglevel info --proxy=${http_proxy} --https-proxy=${https_proxy} install
npm run-script build
}
-
do_install () {
# create directory structure
install -d ${D}${datadir}/www
@@ -31,3 +28,4 @@ do_install () {
find ${D}${datadir}/www -type d -exec chmod a=rx,u+w '{}' +
}
+FILES:${PN} += "${datadir}/www/*"