summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb36
1 files changed, 16 insertions, 20 deletions
diff --git a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
index ee0a386a30..2678e60d07 100644
--- a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
+++ b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
@@ -1,16 +1,3 @@
-# This recipe requires online access to build, as it uses NPM for dependency
-# management and resolution.
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-SRC_URI = "git://github.com/openbmc/webui-vue.git;branch=master;protocol=https"
-SRCREV = "d9566225f1c25b1892c332e0f3a16c1b5e4ba714"
-S = "${WORKDIR}/git"
-
-DEPENDS:prepend = "nodejs-native "
-
# allarch is required because the files this recipe produces (html and
# javascript) are valid for any target, regardless of architecture. The allarch
# class removes your compiler definitions, as it assumes that anything that
@@ -19,31 +6,39 @@ DEPENDS:prepend = "nodejs-native "
# build the library that it then uses to compress the scss into normal css.
# Enabling allarch, then re-adding the compiler flags was the best of the bad
# options
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+DEPENDS:prepend = "nodejs-native "
+SRCREV = "d9566225f1c25b1892c332e0f3a16c1b5e4ba714"
+PV = "1.0+git${SRCPV}"
+# This recipe requires online access to build, as it uses NPM for dependency
+# management and resolution.
+PR = "r1"
+
+SRC_URI = "git://github.com/openbmc/webui-vue.git;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
inherit allarch
+EXTRA_OENPM ?= ""
+
export CXX = "${BUILD_CXX}"
export CC = "${BUILD_CC}"
export CFLAGS = "${BUILD_CFLAGS}"
export CPPFLAGS = "${BUILD_CPPFLAGS}"
export CXXFLAGS = "${BUILD_CXXFLAGS}"
-FILES:${PN} += "${datadir}/www/*"
-
-EXTRA_OENPM ?= ""
-
-# Workaround
+# Workaround
# Network access from task are disabled by default on Yocto 3.5
# https://git.yoctoproject.org/poky/tree/documentation/migration-guides/migration-3.5.rst#n25
do_compile[network] = "1"
-
do_compile () {
cd ${S}
rm -rf node_modules
npm --loglevel info --proxy=${http_proxy} --https-proxy=${https_proxy} install
npm run build ${EXTRA_OENPM}
}
-
do_install () {
# create directory structure
install -d ${D}${datadir}/www
@@ -52,3 +47,4 @@ do_install () {
find ${D}${datadir}/www -type d -exec chmod a=rx,u+w '{}' +
}
+FILES:${PN} += "${datadir}/www/*"