summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb')
-rwxr-xr-xmeta-phosphor/recipes-x86/chassis/x86-power-control_git.bb13
1 files changed, 4 insertions, 9 deletions
diff --git a/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb b/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
index f68629f920..52378e8bbe 100755
--- a/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
+++ b/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
@@ -1,15 +1,13 @@
SUMMARY = "Chassis Power Control service for Intel based platforms"
DESCRIPTION = "Chassis Power Control service for Intel based platforms"
-
-SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=https;branch=master"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRCREV = "8643c79740d21f4a21184de729c19f9aec0f7c48"
-
PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=https;branch=master"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+S = "${WORKDIR}/git"
inherit meson systemd pkgconfig
inherit obmc-phosphor-dbus-service
@@ -19,12 +17,9 @@ def get_service(d):
return "xyz.openbmc_project.Chassis.Control.Power@0.service"
else:
return " ".join(["xyz.openbmc_project.Chassis.Control.Power@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
-
SYSTEMD_SERVICE:${PN} = "${@get_service(d)}"
-
SYSTEMD_SERVICE:${PN} += "chassis-system-reset.service \
chassis-system-reset.target"
-
DEPENDS += " \
boost \
i2c-tools \