summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-devtools/python/python3_%.bbappend7
1 files changed, 0 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-devtools/python/python3_%.bbappend b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
index 69f4e9ab02..324b28ce05 100644
--- a/meta-phosphor/recipes-devtools/python/python3_%.bbappend
+++ b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
@@ -10,11 +10,4 @@ do_install_append_class-target() {
# Even though python3 is built with --without-ensurepip, it still installs
# a large, compressed version of pip. Remove it to free up the space.
rm -rf ${D}${libdir}/python${PYTHON_MAJMIN}/ensurepip
-
- # Remove all python .py files from python recipe. Only the .pyc
- # files are required.
- # The _sysconfigdata*.py files are system configuration files generated
- # during build time. It's used in the yocto packaging process so
- # it is required to remain in the image.
- find ${D}${libdir}/python${PYTHON_MAJMIN} -name \*.py ! -name _sysconfigdata*.py -exec rm {} \;
}