summaryrefslogtreecommitdiff
path: root/meta-security/recipes-kernel/lkrg/lkrg-module_0.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-security/recipes-kernel/lkrg/lkrg-module_0.9.3.bb')
-rw-r--r--meta-security/recipes-kernel/lkrg/lkrg-module_0.9.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-security/recipes-kernel/lkrg/lkrg-module_0.9.3.bb b/meta-security/recipes-kernel/lkrg/lkrg-module_0.9.3.bb
new file mode 100644
index 0000000000..2553974673
--- /dev/null
+++ b/meta-security/recipes-kernel/lkrg/lkrg-module_0.9.3.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Linux Kernel Runtime Guard"
+DESCRIPTION="LKRG performs runtime integrity checking of the Linux \
+kernel and detection of security vulnerability exploits against the kernel."
+SECTION = "security"
+HOMEPAGE = "https://www.openwall.com/lkrg/"
+LICENSE = "GPL-2.0-only"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5105ead24b08a32954f34cbaa7112432"
+
+DEPENDS = "virtual/kernel elfutils"
+
+SRC_URI = "git://github.com/lkrg-org/lkrg.git;protocol=https;branch=main \
+ file://makefile_cleanup.patch \
+"
+
+SRCREV = "c578e9f786299b67ffd62057b4534b0bf4fb7ece"
+
+S = "${WORKDIR}/git"
+
+inherit module kernel-module-split
+
+MAKE_TARGETS = "modules"
+
+MODULE_NAME = "p_lkrg"
+
+module_do_install() {
+ install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
+ install -m 0644 ${MODULE_NAME}.ko \
+ ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
+}
+
+RPROVIDES:${PN} += "kernel-module-lkrg"
+
+COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"