summaryrefslogtreecommitdiff
path: root/meta-security/recipes-kernel/lkrg
diff options
context:
space:
mode:
Diffstat (limited to 'meta-security/recipes-kernel/lkrg')
-rw-r--r--meta-security/recipes-kernel/lkrg/files/makefile_cleanup.patch53
-rw-r--r--meta-security/recipes-kernel/lkrg/lkrg-module_0.9.4.bb (renamed from meta-security/recipes-kernel/lkrg/lkrg-module_0.9.3.bb)16
2 files changed, 10 insertions, 59 deletions
diff --git a/meta-security/recipes-kernel/lkrg/files/makefile_cleanup.patch b/meta-security/recipes-kernel/lkrg/files/makefile_cleanup.patch
deleted file mode 100644
index f29afbe1b5..0000000000
--- a/meta-security/recipes-kernel/lkrg/files/makefile_cleanup.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-Upstream-Status: Inappropriate [embedded specific]
-
-Signed-off-by: Armin Kuster <akuster808@gmail.com>
-
-
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile
-+++ git/Makefile
-@@ -7,15 +7,8 @@
-
- P_OUTPUT = output
- P_PWD ?= $(shell pwd)
--P_KVER ?= $(shell uname -r)
- P_BOOTUP_SCRIPT ?= scripts/bootup/lkrg-bootup.sh
- TARGET := p_lkrg
--ifneq ($(KERNELRELEASE),)
-- KERNEL := /lib/modules/$(KERNELRELEASE)/build
--else
-- ## KERNELRELEASE not set.
-- KERNEL := /lib/modules/$(P_KVER)/build
--endif
-
- #
- # Use DEBUG=on for debug build.
-@@ -94,14 +87,13 @@ $(TARGET)-objs += src/modules/ksyms/p_re
- src/p_lkrg_main.o
-
-
--all:
--# $(MAKE) -C $(KERNEL) M=$(P_PWD) modules CONFIG_DEBUG_SECTION_MISMATCH=y
-- $(MAKE) -C $(KERNEL) M=$(P_PWD) modules
-+modules:
-+ $(MAKE) -C $(KERNEL_SRC) M=$(P_PWD) modules
- mkdir -p $(P_OUTPUT)
- cp $(P_PWD)/$(TARGET).ko $(P_OUTPUT)
-
--install:
-- $(MAKE) -C $(KERNEL) M=$(P_PWD) modules_install
-+moduled_install:
-+ $(MAKE) -C $(KERNEL_SRC) M=$(P_PWD) modules_install
- depmod -a
- $(P_PWD)/$(P_BOOTUP_SCRIPT) install
-
-@@ -109,7 +101,7 @@ uninstall:
- $(P_PWD)/$(P_BOOTUP_SCRIPT) uninstall
-
- clean:
-- $(MAKE) -C $(KERNEL) M=$(P_PWD) clean
-+ $(MAKE) -C $(KERNEL_SRC) M=$(P_PWD) clean
- $(RM) Module.markers modules.order
- $(RM) $(P_PWD)/src/modules/kmod/client/kmod/Module.markers
- $(RM) $(P_PWD)/src/modules/kmod/client/kmod/modules.order
diff --git a/meta-security/recipes-kernel/lkrg/lkrg-module_0.9.3.bb b/meta-security/recipes-kernel/lkrg/lkrg-module_0.9.4.bb
index 2553974673..fa46cb6b5a 100644
--- a/meta-security/recipes-kernel/lkrg/lkrg-module_0.9.3.bb
+++ b/meta-security/recipes-kernel/lkrg/lkrg-module_0.9.4.bb
@@ -5,15 +5,13 @@ SECTION = "security"
HOMEPAGE = "https://www.openwall.com/lkrg/"
LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=5105ead24b08a32954f34cbaa7112432"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3f3e5dd56319d33a1944d635c1c86c6f"
DEPENDS = "virtual/kernel elfutils"
-SRC_URI = "git://github.com/lkrg-org/lkrg.git;protocol=https;branch=main \
- file://makefile_cleanup.patch \
-"
+SRC_URI = "git://github.com/lkrg-org/lkrg.git;protocol=https;branch=main"
-SRCREV = "c578e9f786299b67ffd62057b4534b0bf4fb7ece"
+SRCREV = "c58cb52145b8e8ccc6bd19079f5c835933281cdc"
S = "${WORKDIR}/git"
@@ -21,7 +19,13 @@ inherit module kernel-module-split
MAKE_TARGETS = "modules"
-MODULE_NAME = "p_lkrg"
+MODULE_NAME = "lkrg"
+
+do_configure:append () {
+ sed -i -e 's/^all/modules/' ${S}/Makefile
+ sed -i -e 's/^install/modules_install/' ${S}/Makefile
+ sed -i -e 's/KERNEL/KERNEL_SRC/g' ${S}/Makefile
+}
module_do_install() {
install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}