summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-core/glibc/glibc_2.37.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-core/glibc/glibc_2.37.bb')
-rw-r--r--poky/meta/recipes-core/glibc/glibc_2.37.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/poky/meta/recipes-core/glibc/glibc_2.37.bb b/poky/meta/recipes-core/glibc/glibc_2.37.bb
index b27f98fb19..caf454f368 100644
--- a/poky/meta/recipes-core/glibc/glibc_2.37.bb
+++ b/poky/meta/recipes-core/glibc/glibc_2.37.bb
@@ -49,6 +49,7 @@ SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
file://0020-tzselect.ksh-Use-bin-sh-default-shell-interpreter.patch \
file://0021-fix-create-thread-failed-in-unprivileged-process-BZ-.patch \
file://0022-Avoid-hardcoded-build-time-paths-in-the-output-binar.patch \
+ file://0023-CVE-2023-4527.patch \
"
S = "${WORKDIR}/git"
B = "${WORKDIR}/build-${TARGET_SYS}"
@@ -103,10 +104,12 @@ do_configure () {
# version check and doesn't really help with anything
(cd ${S} && gnu-configize) || die "failure in running gnu-configize"
find ${S} -name "configure" | xargs touch
- CPPFLAGS="" oe_runconf
+ CPPFLAGS="" LD="${HOST_PREFIX}ld.bfd ${TOOLCHAIN_OPTIONS}" oe_runconf
}
LDFLAGS += "-fuse-ld=bfd"
+CC += "-fuse-ld=bfd"
+
do_compile () {
base_do_compile
echo "Adjust ldd script"