summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb')
-rw-r--r--poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb27
1 files changed, 21 insertions, 6 deletions
diff --git a/poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb b/poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb
index 251e0d0348..f7108013d3 100644
--- a/poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb
+++ b/poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb
@@ -7,10 +7,9 @@ BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
SECTION = "libs"
# helper program gcryptrnd and getrandom are under GPL, rest LGPL
-LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & GPL-3.0-or-later"
+LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
LICENSE:${PN} = "LGPL-2.1-or-later"
LICENSE:${PN}-dev = "GPL-2.0-or-later & LGPL-2.1-or-later"
-LICENSE:dumpsexp-dev = "GPL-3.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \
@@ -18,6 +17,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
"
DEPENDS = "libgpg-error"
+RDEPENDS:${PN}-ptest = "bash make"
UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
@@ -25,6 +25,7 @@ SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \
file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
+ file://run-ptest \
"
SRC_URI[sha256sum] = "ef14ae546b0084cd84259f61a55e07a38c3b53afc0f546bffcef2f01baffe9de"
@@ -33,11 +34,13 @@ CVE_CHECK_IGNORE += "CVE-2018-12433 CVE-2018-12438"
BINCONFIG = "${bindir}/libgcrypt-config"
-inherit autotools texinfo binconfig-disabled pkgconfig
+inherit autotools texinfo binconfig-disabled pkgconfig ptest
EXTRA_OECONF = "--disable-asm"
EXTRA_OEMAKE:class-target = "LIBTOOLFLAGS='--tag=CC'"
+PRIVATE_LIBS:${PN}-ptest:append = " libgcrypt.so.20"
+
PACKAGECONFIG ??= "capabilities"
PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
@@ -52,9 +55,21 @@ do_install:append() {
install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
}
-PACKAGES =+ "dumpsexp-dev"
+do_install_ptest() {
+ cp -r --preserve=mode,links -v ${S} ${D}${PTEST_PATH}
+ cp -r --preserve=mode,links -v ${B} ${D}${PTEST_PATH}
+ rm ${D}${PTEST_PATH}/build/cipher/gost-s-box
+ rm ${D}${PTEST_PATH}/build/doc/yat2m
+ rm ${D}${PTEST_PATH}/build/libtool
+ rm ${D}${PTEST_PATH}/build/config.status
+ rm ${D}${PTEST_PATH}/build/config.log
+ rm ${D}${PTEST_PATH}/build/src/mpicalc
+ rm ${D}${PTEST_PATH}/${BP}/autom4te* -rf
+ sed -i -e 's/Makefile:.*/Makefile-disabled:/' ${D}${PTEST_PATH}/build/Makefile
+ find ${D}/${PTEST_PATH}/build -name "*.cmake" -or -name "Makefile" \
+ | xargs sed -e "s|${WORKDIR}|${PTEST_PATH}|g" -e "s|${WORKDIR}/recipe-sysroot-native||g" -i
+}
-FILES:${PN}-dev += "${bindir}/hmac256"
-FILES:dumpsexp-dev += "${bindir}/dumpsexp"
+FILES:${PN}-dev += "${bindir}/hmac256 ${bindir}/dumpsexp"
BBCLASSEXTEND = "native nativesdk"