summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-support/libgit2/libgit2_1.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-support/libgit2/libgit2_1.5.0.bb')
-rw-r--r--poky/meta/recipes-support/libgit2/libgit2_1.5.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/poky/meta/recipes-support/libgit2/libgit2_1.5.0.bb b/poky/meta/recipes-support/libgit2/libgit2_1.5.0.bb
new file mode 100644
index 0000000000..ee4d79b11a
--- /dev/null
+++ b/poky/meta/recipes-support/libgit2/libgit2_1.5.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "the Git linkable library"
+HOMEPAGE = "http://libgit2.github.com/"
+LICENSE = "GPL-2.0-with-GCC-exception & MIT & OpenSSL & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=112e6bb421dea73cd41de09e777f2d2c"
+
+DEPENDS = "curl openssl zlib libssh2 libgcrypt libpcre2"
+
+SRC_URI = "git://github.com/libgit2/libgit2.git;branch=main;protocol=https"
+SRCREV = "fbea439d4b6fc91c6b619d01b85ab3b7746e4c19"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "\
+ -DBUILD_CLAR=OFF \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DLIB_INSTALL_DIR=${libdir} \
+ -DREGEX_BACKEND='pcre2' \
+"
+
+BBCLASSEXTEND = "native"