summaryrefslogtreecommitdiff
path: root/packages/a/bpe
diff options
context:
space:
mode:
Diffstat (limited to 'packages/a/bpe')
-rw-r--r--packages/a/bpe/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/a/bpe/Makefile b/packages/a/bpe/Makefile
new file mode 100644
index 0000000..177266b
--- /dev/null
+++ b/packages/a/bpe/Makefile
@@ -0,0 +1,40 @@
+#
+# Project Home:
+# ============
+# https://sourceforge.net/projects/bpe
+#
+# Downloads:
+# =========
+# https://downloads.sourceforge.net/project/bpe/BPE/${VERSION}
+#
+
+url = https://downloads.sourceforge.net/project/bpe/BPE
+
+versions = 2.01.00
+
+pkgname = bpe
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ version=`echo $$tarball | sed 's/\([a-zA-Z0-9-]*\)\([0-9][.0-9]*[.0-9]*\)\(\..*\)/\2/'` ; \
+ wget -N $(url)/$$version/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)