summaryrefslogtreecommitdiff
path: root/packages/a/quota/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/a/quota/Makefile')
-rw-r--r--packages/a/quota/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/packages/a/quota/Makefile b/packages/a/quota/Makefile
new file mode 100644
index 0000000..88d3199
--- /dev/null
+++ b/packages/a/quota/Makefile
@@ -0,0 +1,44 @@
+#
+# Project Home:
+# ============
+# https://sourceforge.net/projects/linuxquota
+#
+# Downloads:
+# =========
+# https://downloads.sourceforge.net/project/linuxquota/quota-tools/${VERSION}
+#
+
+url = https://downloads.sourceforge.net/project/linuxquota/quota-tools
+
+versions = 3.17 4.01 4.02 4.03 4.06 4.09
+
+pkgname = quota
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ version=`echo $$tarball | sed 's/\([a-zA-Z-]*\)\([0-9][.0-9]*[.0-9]*\)\(\..*\)/\2/'` ; \
+ wget -N $(url)/$$version/$$tarball ; \
+ tar xzf $$tarball ; \
+ mv $(pkgname)-tools $(pkgname)-$$version ; \
+ tar czf $$tarball $(pkgname)-$$version ; \
+ rm -rf $(pkgname)-$$version ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)