summaryrefslogtreecommitdiff
path: root/packages/a/shadow
diff options
context:
space:
mode:
Diffstat (limited to 'packages/a/shadow')
-rw-r--r--packages/a/shadow/Makefile78
1 files changed, 78 insertions, 0 deletions
diff --git a/packages/a/shadow/Makefile b/packages/a/shadow/Makefile
new file mode 100644
index 0000000..4db05f2
--- /dev/null
+++ b/packages/a/shadow/Makefile
@@ -0,0 +1,78 @@
+#
+# Project Home:
+# ============
+# https://github.com/shadow-maint/shadow
+#
+# Downloads:
+# =========
+# https://github.com/shadow-maint/shadow/releases
+#
+
+
+url = https://github.com/shadow-maint
+
+repo_name = shadow
+
+#
+# List of upstream versions to be extracted:
+# =========================================
+# hash | tag
+# ----------------------------------------+-----
+revisions = 2cc7da6058152ec0cd338d4e15d29bd7124ae3d7:4.8.1
+revisions += 6f9124b7f73d6e31f96a0d441d7a3e54d835642d:4.9
+revisions += 868d7b34ea4abfcd25170c8e9d69e97fc55d6a2a:4.10
+revisions += 25337787e73e115408294775872a035cbc5c467a:4.12
+revisions += 01b224349bbeda7daaf08f6004bdf028456e2d86:4.12.3
+revisions += 24b44b686ea2221405cfd806dede046cf1fd9584:4.13
+
+git_repo = .git_clone
+
+suffix = tar.xz
+
+versions = $(foreach tag, $(revisions), $(shell echo $(tag) | cut -f 2 -d ':'))
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(repo_name)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+TARGETS = repository_clean
+
+all: $(TARGETS)
+
+.PHONY: downloads_clean repository_clean
+
+$(git_repo):
+ @echo -e "\n======= Clone $(repo_name).git repository =======\n"
+ @rm -rf $(repo_name)
+ @git clone $(url)/$(repo_name).git $(repo_name)
+ @touch $@
+
+$(tarballs): $(git_repo)
+ @for revision in $(revisions) ; do \
+ hash=`echo $$revision | cut -f 1 -d ':'` ; \
+ version=`echo $$revision | cut -f 2 -d ':'` ; \
+ if [ ! -f $(repo_name)-$$version.$(suffix) ]; then \
+ echo -e "\n======= Creating '$(repo_name)-$$version.$(suffix)' snapshot =======" ; \
+ ( cd $(repo_name) && \
+ git archive --format=tar --prefix=$(repo_name)-$$version/ $$hash | \
+ xz >../$(repo_name)-$$version.$(suffix) ) ; \
+ tar xJf $(repo_name)-$$version.$(suffix) ; \
+ ( cd $(repo_name)-$$version ; \
+ autoreconf -v -f --install ; rm -rf autom4te.cache .builds .git* .travis.yml *~ ) ; \
+ tar cJf $(repo_name)-$$version.$(suffix) $(repo_name)-$$version ; \
+ rm -rf $(repo_name)-$$version ; \
+ fi ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+repository_clean: $(sha1s)
+ @echo -e "\n======= Remove cloned $(repo_name).git repository =======\n"
+ @rm -rf $(git_repo) $(repo_name)
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
+ @rm -rf $(git_repo) $(repo_name)