summaryrefslogtreecommitdiff
path: root/packages/d/ruby/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/d/ruby/Makefile')
-rw-r--r--packages/d/ruby/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/d/ruby/Makefile b/packages/d/ruby/Makefile
new file mode 100644
index 0000000..6e71341
--- /dev/null
+++ b/packages/d/ruby/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# https://www.ruby-lang.org
+#
+# Downloads:
+# =========
+# https://www.ruby-lang.org/en/downloads
+# https://cache.ruby-lang.org/pub/ruby
+#
+
+url = https://cache.ruby-lang.org/pub/ruby
+
+versions = 3.0.3
+versions += 3.1.0 3.1.2
+versions += 3.2.0 3.2.2
+
+pkgname = ruby
+suffix = tar.xz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ version=`echo $$tarball | sed 's/\([a-zA-Z-]*\)\([0-9][.][0-9]*[.][0-9]*\)\([\.].*\)/\2/' | cut -f1,2 -d'.'` ; \
+ wget -N $(url)/$$version/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)