summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAbhilash Raju <abhilash.kollam@gmail.com>2023-07-17 16:53:11 +0300
committerEd Tanous <ed@tanous.net>2023-12-08 20:22:49 +0300
commit8e3f70321e71009c76c11fa90a6ca669f5941fc5 (patch)
tree86debc04f26219bddccd2dd22e860aa310b8f14d /meson.build
parentdfd5547b98d0a7360ca6cfe8b48b9d7ce2cf95d2 (diff)
downloadbmcweb-8e3f70321e71009c76c11fa90a6ca669f5941fc5.tar.xz
Reponse: Fix incomplete implementation in write
Write function in http_response.hpp missing implementation for first write after changing from filebody. Usecase: Current resonse type is filebody. Developer tries to change the body type to stringbody by calling write function. Observed: The write fails to update the body type. Expected: Write should succeed and body should change to string body. Tested: Unit test has been added for crow::Response. Manual sanity test done for file offloads using curl. Change-Id: Icbf8585b5b04c3ac5120d7b334c13d89ed3eb4aa Signed-off-by: Abhilash Raju <abhilash.kollam@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f3e0ed3be8..002b94900c 100644
--- a/meson.build
+++ b/meson.build
@@ -409,6 +409,7 @@ srcfiles_unittest = files(
'test/http/crow_getroutes_test.cpp',
'test/http/http_connection_test.cpp',
'test/http/router_test.cpp',
+ 'test/http/http_response_test.cpp',
'test/http/utility_test.cpp',
'test/http/verb_test.cpp',
'test/include/dbus_utility_test.cpp',