summaryrefslogtreecommitdiff
path: root/meta-aspeed/conf
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 17:13:33 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 00:56:33 +0300
commitb9799be79de3f0a15a14be392ee90574433435ad (patch)
tree3c65475447a820e83c873a0371ac0717763b82c3 /meta-aspeed/conf
parented2ee5d25d6f756fe721e16b39aabbd475d982d9 (diff)
downloadopenbmc-b9799be79de3f0a15a14be392ee90574433435ad.tar.xz
meta-aspeed: prep for new override syntax
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I8135871ae0e3b360aff7d878f7cf04a2504f2dd0
Diffstat (limited to 'meta-aspeed/conf')
-rw-r--r--meta-aspeed/conf/layer.conf4
-rw-r--r--meta-aspeed/conf/machine/include/aspeed.inc22
2 files changed, 13 insertions, 13 deletions
diff --git a/meta-aspeed/conf/layer.conf b/meta-aspeed/conf/layer.conf
index c0289753f..00302ddf5 100644
--- a/meta-aspeed/conf/layer.conf
+++ b/meta-aspeed/conf/layer.conf
@@ -6,5 +6,5 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "aspeed-layer"
BBFILE_PATTERN_aspeed-layer := "^${LAYERDIR}/"
-LAYERVERSION_aspeed-layer = "1"
-LAYERSERIES_COMPAT_aspeed-layer = "gatesgarth hardknott"
+LAYERVERSION:aspeed-layer = "1"
+LAYERSERIES_COMPAT_aspeed-layer = "gatesgarth hardknott honister"
diff --git a/meta-aspeed/conf/machine/include/aspeed.inc b/meta-aspeed/conf/machine/include/aspeed.inc
index fdc411981..628a73b1d 100644
--- a/meta-aspeed/conf/machine/include/aspeed.inc
+++ b/meta-aspeed/conf/machine/include/aspeed.inc
@@ -3,9 +3,9 @@ PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-aspeed"
PREFERRED_PROVIDER_u-boot ?= "u-boot-aspeed"
PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-fw-utils-aspeed"
-PREFERRED_PROVIDER_virtual/bootloader_aspeed-g6 ?= "u-boot-aspeed-sdk"
-PREFERRED_PROVIDER_u-boot_aspeed-g6 ?= "u-boot-aspeed-sdk"
-PREFERRED_PROVIDER_u-boot-fw-utils_aspeed-g6 ?= "u-boot-fw-utils-aspeed-sdk"
+PREFERRED_PROVIDER_virtual/bootloader:aspeed-g6 ?= "u-boot-aspeed-sdk"
+PREFERRED_PROVIDER_u-boot:aspeed-g6 ?= "u-boot-aspeed-sdk"
+PREFERRED_PROVIDER_u-boot-fw-utils:aspeed-g6 ?= "u-boot-fw-utils-aspeed-sdk"
# Build a FIT image and stuff core-image-minimal in it by default.
KERNEL_IMAGETYPE ?= "fitImage"
@@ -29,12 +29,12 @@ MACHINEOVERRIDES =. "aspeed:"
SERIAL_CONSOLES ?= "115200;ttyS4"
-DEFAULTTUNE_aspeed-g5 ?= "arm1176jzs"
-DEFAULTTUNE_aspeed-g6 ?= "armv7ahf-vfpv4d16"
+DEFAULTTUNE:aspeed-g5 ?= "arm1176jzs"
+DEFAULTTUNE:aspeed-g6 ?= "armv7ahf-vfpv4d16"
-UBOOT_ENTRYPOINT_aspeed-g4 ?= "0x40001000"
-UBOOT_ENTRYPOINT_aspeed-g5 ?= "0x80001000"
-UBOOT_ENTRYPOINT_aspeed-g6 ?= "0x80001000"
-UBOOT_LOADADDRESS_aspeed-g4 ?= "0x40001000"
-UBOOT_LOADADDRESS_aspeed-g5 ?= "0x80001000"
-UBOOT_LOADADDRESS_aspeed-g6 ?= "0x80001000"
+UBOOT_ENTRYPOINT:aspeed-g4 ?= "0x40001000"
+UBOOT_ENTRYPOINT:aspeed-g5 ?= "0x80001000"
+UBOOT_ENTRYPOINT:aspeed-g6 ?= "0x80001000"
+UBOOT_LOADADDRESS:aspeed-g4 ?= "0x40001000"
+UBOOT_LOADADDRESS:aspeed-g5 ?= "0x80001000"
+UBOOT_LOADADDRESS:aspeed-g6 ?= "0x80001000"