summaryrefslogtreecommitdiff
path: root/meta-aspeed/recipes-bsp
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 17:13:33 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 00:56:33 +0300
commitb9799be79de3f0a15a14be392ee90574433435ad (patch)
tree3c65475447a820e83c873a0371ac0717763b82c3 /meta-aspeed/recipes-bsp
parented2ee5d25d6f756fe721e16b39aabbd475d982d9 (diff)
downloadopenbmc-b9799be79de3f0a15a14be392ee90574433435ad.tar.xz
meta-aspeed: prep for new override syntax
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I8135871ae0e3b360aff7d878f7cf04a2504f2dd0
Diffstat (limited to 'meta-aspeed/recipes-bsp')
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb10
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc2
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb2
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb12
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb12
5 files changed, 19 insertions, 19 deletions
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
index 727c62d27..56468270a 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
@@ -8,17 +8,17 @@ inherit socsec-sign
PROVIDES += "u-boot"
DEPENDS += "bc-native dtc-native"
-SRC_URI_append_df-phosphor-mmc = " file://u-boot-env-ast2600.txt"
+SRC_URI:append:df-phosphor-mmc = " file://u-boot-env-ast2600.txt"
SRC_URI += " \
file://rsa_oem_dss_key.pem;sha256sum=64a379979200d39949d3e5b0038e3fdd5548600b2f7077a17e35422336075ad4 \
file://rsa_pub_oem_dss_key.pem;sha256sum=40132a694a10af2d1b094b1cb5adab4d6b4db2a35e02d848b2b6a85e60738264 \
"
-UBOOT_ENV_SIZE_df-phosphor-mmc = "0x10000"
-UBOOT_ENV_df-phosphor-mmc = "u-boot-env"
-UBOOT_ENV_SUFFIX_df-phosphor-mmc = "bin"
+UBOOT_ENV_SIZE:df-phosphor-mmc = "0x10000"
+UBOOT_ENV:df-phosphor-mmc = "u-boot-env"
+UBOOT_ENV_SUFFIX:df-phosphor-mmc = "bin"
-do_compile_append() {
+do_compile:append() {
if [ -n "${UBOOT_ENV}" ]
then
# Generate redundant environment image
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc
index 0b9bc20d2..19de5d2c6 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc
@@ -182,7 +182,7 @@ do_install () {
}
-FILES_${PN} = "/boot ${sysconfdir} ${datadir}"
+FILES:${PN} = "/boot ${sysconfdir} ${datadir}"
do_deploy () {
if [ -n "${UBOOT_CONFIG}" ]
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
index 8cebe5ab3..395f5ab57 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
@@ -6,4 +6,4 @@ DEPENDS += "dtc-native"
# FIXME this can/should be removed when we have rebased off our
# 2016 snapshot onto a more modern (circa late 2018) u-boot tree.
-BUILD_CFLAGS_remove = "-isystem${STAGING_INCDIR_NATIVE}"
+BUILD_CFLAGS:remove = "-isystem${STAGING_INCDIR_NATIVE}"
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index cebbee6e6..13a4081b0 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -9,11 +9,11 @@ SRC_URI += "file://fw_env_ast2600_nor.config"
SRC_URI += "file://fw_env_ast2600_mmc.config"
ENV_CONFIG_FILE = "fw_env_ast2600_nor.config"
-ENV_CONFIG_FILE_df-phosphor-mmc = "fw_env_ast2600_mmc.config"
+ENV_CONFIG_FILE:df-phosphor-mmc = "fw_env_ast2600_mmc.config"
-INSANE_SKIP_${PN} = "already-stripped"
-EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
-EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+INSANE_SKIP:${PN} = "already-stripped"
+EXTRA_OEMAKE:class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
+EXTRA_OEMAKE:class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
inherit uboot-config
@@ -31,13 +31,13 @@ do_install () {
install -m 644 ${WORKDIR}/${ENV_CONFIG_FILE} ${D}${sysconfdir}/fw_env.config
}
-do_install_class-cross () {
+do_install:class-cross () {
install -d ${D}${bindir_cross}
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
}
-SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
+SYSROOT_DIRS:append:class-cross = " ${bindir_cross}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
BBCLASSEXTEND = "cross"
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb
index e9f724df2..0ec64ce8e 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb
@@ -9,9 +9,9 @@ DEPENDS += "mtd-utils"
PROVIDES += "u-boot-fw-utils"
-INSANE_SKIP_${PN} = "already-stripped"
-EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
-EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+INSANE_SKIP:${PN} = "already-stripped"
+EXTRA_OEMAKE:class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
+EXTRA_OEMAKE:class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
inherit uboot-config
@@ -30,15 +30,15 @@ do_install () {
install -m 644 ${WORKDIR}/alt_fw_env.config ${D}${sysconfdir}/alt_fw_env.config
}
-do_install_class-cross () {
+do_install:class-cross () {
install -d ${D}${bindir_cross}
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
}
-SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
+SYSROOT_DIRS:append:class-cross = " ${bindir_cross}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
BBCLASSEXTEND = "cross"
-RDEPENDS_${PN} = "udev-aspeed-mtd-partitions"
+RDEPENDS:${PN} = "udev-aspeed-mtd-partitions"