summaryrefslogtreecommitdiff
path: root/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-02-10 04:48:19 +0300
committerWilliam A. Kennington III <wak@google.com>2021-02-11 08:39:06 +0300
commitb2c5306a488d7add62654d4c1d794b12cc2519ef (patch)
treef5571ac34852ff386ee02789c742d2ec5c2a4c4d /meta-google/recipes-extended/libconfig/conf2struct-native_git.bb
parent2d656b42b4966e206c207117aef024760e7bee10 (diff)
downloadopenbmc-b2c5306a488d7add62654d4c1d794b12cc2519ef.tar.xz
meta-google: conf2struct-native: Add package
Google-Bug-Id: 179618161 Upstream: 8ac594bdf054082ca6dbe35c4345759fe4c31669 Change-Id: I1f86406891528241295455c6498f2a488d5b1b78 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-extended/libconfig/conf2struct-native_git.bb')
-rw-r--r--meta-google/recipes-extended/libconfig/conf2struct-native_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb b/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb
new file mode 100644
index 000000000..1a77f4de1
--- /dev/null
+++ b/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb
@@ -0,0 +1,32 @@
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1b886630cdc9a17c26250934beda407d"
+
+PV = "0.1+git${SRCPV}"
+SRC_URI = "git://github.com/yrutschle/conf2struct"
+SRCREV = "e8468017b27211b1c452f8df0afe6f19e97035a4"
+S = "${WORKDIR}/git"
+
+SRC_URI += " \
+ file://0001-makefile-Add-missing-LDFLAGS.patch \
+ file://0001-conf2struct-Use-the-right-perl.patch \
+ "
+
+inherit native
+
+DEPENDS += " \
+ libconfig-native \
+ libconfig-perl-native \
+ "
+
+EXTRA_OEMAKE += " \
+ DESTDIR=${D} \
+ prefix=${prefix} \
+ "
+
+do_compile() {
+ oe_runmake checker
+}
+
+do_install() {
+ oe_runmake install
+}