summaryrefslogtreecommitdiff
path: root/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-extended/libconfig/conf2struct-native_git.bb')
-rw-r--r--meta-google/recipes-extended/libconfig/conf2struct-native_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb b/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb
new file mode 100644
index 000000000..1a77f4de1
--- /dev/null
+++ b/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb
@@ -0,0 +1,32 @@
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1b886630cdc9a17c26250934beda407d"
+
+PV = "0.1+git${SRCPV}"
+SRC_URI = "git://github.com/yrutschle/conf2struct"
+SRCREV = "e8468017b27211b1c452f8df0afe6f19e97035a4"
+S = "${WORKDIR}/git"
+
+SRC_URI += " \
+ file://0001-makefile-Add-missing-LDFLAGS.patch \
+ file://0001-conf2struct-Use-the-right-perl.patch \
+ "
+
+inherit native
+
+DEPENDS += " \
+ libconfig-native \
+ libconfig-perl-native \
+ "
+
+EXTRA_OEMAKE += " \
+ DESTDIR=${D} \
+ prefix=${prefix} \
+ "
+
+do_compile() {
+ oe_runmake checker
+}
+
+do_install() {
+ oe_runmake install
+}