summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc/meta-common
diff options
context:
space:
mode:
authorJae Hyun Yoo <jae.hyun.yoo@linux.intel.com>2021-08-06 20:55:59 +0300
committerVernon Mauery <vernon.mauery@linux.intel.com>2021-08-13 19:02:07 +0300
commit24e16a2cb140a5ab7c27d9f16f50ca6ce9531b9b (patch)
tree7ad9b1933fac80e4730c7f1ecba60a8bd4bcda48 /meta-intel-openbmc/meta-common
parent28a6a30e9d546c70976549cffd7f970509220174 (diff)
downloadopenbmc-24e16a2cb140a5ab7c27d9f16f50ca6ce9531b9b.tar.xz
meta-intel-openbmc: prep for new override syntax
Ran `scripts/contrib/convert-overrides.py` from upstream Yocto and fixed up a few by hand that were missed. Tested: Built s2600wf. Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@linux.intel.com> Change-Id: I983385c8cdd4e2727c5c1a3d56952d6ac7fd89cc
Diffstat (limited to 'meta-intel-openbmc/meta-common')
-rw-r--r--meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend16
-rw-r--r--meta-intel-openbmc/meta-common/recipes-extended/rsyslog/rsyslog_%.bbappend10
-rwxr-xr-xmeta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb10
-rw-r--r--meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb24
-rw-r--r--meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb4
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb4
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend6
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend6
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend6
-rw-r--r--meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend2
15 files changed, 49 insertions, 49 deletions
diff --git a/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb b/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
index 1236cbfc7..7d30a7d83 100644
--- a/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
@@ -11,6 +11,6 @@ SRCREV = "4a6e45c4c2f38bc64afe5faac05ea82b3adb8d93"
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.HostErrorMonitor.service"
+SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.HostErrorMonitor.service"
EXTRA_OECMAKE = "-DYOCTO=1"
diff --git a/meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend b/meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend
index 090b40e40..6f19a5e90 100644
--- a/meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend
@@ -1,9 +1,9 @@
# Remove these files since they are provided by obmc-intel-targets
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-host-start@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-host-stop@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-host-reboot@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-host-startmin@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-chassis-poweron@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-chassis-poweroff@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-chassis-hard-poweroff@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-chassis-powerreset@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-host-start@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-host-stop@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-host-reboot@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-host-startmin@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-chassis-poweron@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-chassis-poweroff@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-chassis-hard-poweroff@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-chassis-powerreset@.target"
diff --git a/meta-intel-openbmc/meta-common/recipes-extended/rsyslog/rsyslog_%.bbappend b/meta-intel-openbmc/meta-common/recipes-extended/rsyslog/rsyslog_%.bbappend
index c42693787..20cbaf8cd 100644
--- a/meta-intel-openbmc/meta-common/recipes-extended/rsyslog/rsyslog_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-extended/rsyslog/rsyslog_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://rsyslog.conf \
file://rsyslog.logrotate \
@@ -7,11 +7,11 @@ SRC_URI += "file://rsyslog.conf \
file://rsyslog-override.conf \
"
-FILES_${PN} += "${systemd_system_unitdir}/rsyslog.service.d/rsyslog-override.conf"
+FILES:${PN} += "${systemd_system_unitdir}/rsyslog.service.d/rsyslog-override.conf"
-PACKAGECONFIG_append = " imjournal"
+PACKAGECONFIG:append = " imjournal"
-do_install_append() {
+do_install:append() {
install -m 0644 ${WORKDIR}/rotate-event-logs.service ${D}${systemd_system_unitdir}
install -d ${D}${systemd_system_unitdir}/rsyslog.service.d
install -m 0644 ${WORKDIR}/rsyslog-override.conf \
@@ -21,4 +21,4 @@ do_install_append() {
rm ${D}${sysconfdir}/rsyslog.d/imjournal.conf
}
-SYSTEMD_SERVICE_${PN} += " rotate-event-logs.service"
+SYSTEMD_SERVICE:${PN} += " rotate-event-logs.service"
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb b/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
index 7327630f5..77d945c45 100755
--- a/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
@@ -21,12 +21,12 @@ LIBRARY_NAMES = "libzinteloemcmds.so"
HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
-FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
-FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
+FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
-do_install_append(){
+do_install:append(){
install -d ${D}${includedir}/intel-ipmi-oem
install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/intel-ipmi-oem
}
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb b/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
index 8c0dfbf1c..098a91eb7 100644
--- a/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
+++ b/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
@@ -16,29 +16,29 @@ PROVIDES += "virtual/obmc-fan-mgmt"
PROVIDES += "virtual/obmc-flash-mgmt"
PROVIDES += "virtual/obmc-system-mgmt"
-RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-mgmt"
-RPROVIDES_${PN}-fans += "virtual-obmc-fan-mgmt"
-RPROVIDES_${PN}-flash += "virtual-obmc-flash-mgmt"
-RPROVIDES_${PN}-system += "virtual-obmc-system-mgmt"
+RPROVIDES:${PN}-chassis += "virtual-obmc-chassis-mgmt"
+RPROVIDES:${PN}-fans += "virtual-obmc-fan-mgmt"
+RPROVIDES:${PN}-flash += "virtual-obmc-flash-mgmt"
+RPROVIDES:${PN}-system += "virtual-obmc-system-mgmt"
-SUMMARY_${PN}-chassis = "Intel Chassis"
-RDEPENDS_${PN}-chassis = " \
+SUMMARY:${PN}-chassis = "Intel Chassis"
+RDEPENDS:${PN}-chassis = " \
x86-power-control \
obmc-host-failure-reboots \
"
-SUMMARY_${PN}-fans = "Intel Fans"
-RDEPENDS_${PN}-fans = " \
+SUMMARY:${PN}-fans = "Intel Fans"
+RDEPENDS:${PN}-fans = " \
phosphor-pid-control \
"
-SUMMARY_${PN}-flash = "Intel Flash"
-RDEPENDS_${PN}-flash = " \
+SUMMARY:${PN}-flash = "Intel Flash"
+RDEPENDS:${PN}-flash = " \
obmc-control-bmc \
"
-SUMMARY_${PN}-system = "Intel System"
-RDEPENDS_${PN}-system = " \
+SUMMARY:${PN}-system = "Intel System"
+RDEPENDS:${PN}-system = " \
bmcweb \
entity-manager \
intel-ipmi-oem \
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb b/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
index effd89b40..76d125ce8 100644
--- a/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
@@ -12,7 +12,7 @@ SRCREV = "bcc7ce1f418c1a16a7868fee62499fa677242254"
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.PFR.Manager.service"
+SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.PFR.Manager.service"
DEPENDS += " \
sdbusplus \
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
index 0d1d016fe..625a81921 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
@@ -7,5 +7,5 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit phosphor-mapper
inherit native
-PHOSPHOR_MAPPER_SERVICE_append = " com.intel"
-PHOSPHOR_MAPPER_INTERFACE_append = " com.intel"
+PHOSPHOR_MAPPER_SERVICE:append = " com.intel"
+PHOSPHOR_MAPPER_INTERFACE:append = " com.intel"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
index cdb88bbfe..ea2fe75bb 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
@@ -25,7 +25,7 @@ PACKAGECONFIG[libintel_dbus] = " \
libsystemd \
"
-PACKAGECONFIG_remove_class-native = "libintel_dbus"
-PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus"
+PACKAGECONFIG:remove:class-native = "libintel_dbus"
+PACKAGECONFIG:remove:class-nativesdk = "libintel_dbus"
BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
index ef991a58b..50f276aa6 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
@@ -1 +1 @@
-PHOSPHOR_MAPPER_CONFIGS_append_intel = " intel-dbus-interfaces-mapper-config-native"
+PHOSPHOR_MAPPER_CONFIGS:append:intel = " intel-dbus-interfaces-mapper-config-native"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
index 4521fe8f8..6d6912dca 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -1,5 +1,5 @@
-FILESEXTRAPATHS_prepend_intel := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:intel := "${THISDIR}/${PN}:"
inherit obmc-phosphor-systemd
-SYSTEMD_SERVICE_${PN}_intel = "phosphor-pid-control.service"
-EXTRA_OECONF_intel = "--enable-configure-dbus=yes"
+SYSTEMD_SERVICE:${PN}:intel = "phosphor-pid-control.service"
+EXTRA_OECONF:intel = "--enable-configure-dbus=yes"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index 876567f9a..652481d79 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -1,4 +1,4 @@
-do_install_append_intel(){
+do_install:append:intel(){
install -d ${D}${includedir}/phosphor-ipmi-host
install -m 0644 -D ${S}/sensorhandler.hpp ${D}${includedir}/phosphor-ipmi-host
install -m 0644 -D ${S}/selutility.hpp ${D}${includedir}/phosphor-ipmi-host
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
index e8cbbe928..29b98581f 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI_append = " file://ipmb-channels.json"
+SRC_URI:append = " file://ipmb-channels.json"
-do_install_append(){
+do_install:append(){
install -m 0644 -D ${WORKDIR}/ipmb-channels.json \
${D}/usr/share/ipmbbridge
}
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
index c7e2194ca..49b23e598 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
@@ -1 +1 @@
-PACKAGECONFIG_append_intel = " log-threshold"
+PACKAGECONFIG:append:intel = " log-threshold"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
index 590e9e629..a80a6d42d 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend_intel := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:intel := "${THISDIR}/${PN}:"
-SRC_URI_append_intel = " file://config.json"
+SRC_URI:append:intel = " file://config.json"
-do_compile_prepend_intel() {
+do_compile:prepend:intel() {
cp -r ${WORKDIR}/config.json ${S}/
}
diff --git a/meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
index 5d47989b7..b27f9080b 100644
--- a/meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -1,2 +1,2 @@
# Use PLT_RST to detect warm resets
-EXTRA_OECMAKE_intel += "-DUSE_PLT_RST=ON"
+EXTRA_OECMAKE:intel += "-DUSE_PLT_RST=ON"