summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-12-14 03:00:02 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-12-14 18:04:12 +0300
commit691a8e0474d482e2487b7ba29818cbb758bdd2b2 (patch)
tree64576a8263c73f905db0b5ab25e1077219394bda /meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
parent9721e3d7702b15c8b5b164ab707af082c2c78139 (diff)
downloadopenbmc-691a8e0474d482e2487b7ba29818cbb758bdd2b2.tar.xz
meta-phosphor: cmake packages: add pkgconfig
With the latest Yocto we see failures: ``` 17:14:36 | CMake Error at /home/jenkins-op/workspace/ci-openbmc/distro/ubuntu/label/docker-builder/target/tiogapass/build/work/arm1176jzs-openbmc-linux-gnueabi/phosphor-ipmi-ipmb/0.1+gitAUTOINC+8227626764-r0/recipe-sysroot-native/usr/share/cmake-3.21/Modules/FindPackageHandleStandardArgs.cmake:230 (message): 17:14:36 | Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) ``` Add the correct inherit for ipmb-ipmb. Pre-emptively add for any recipe which does 'inherit cmake'. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Ib3327af0f19268d1f5b70259c3445b0985da9fa0
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
index 1db304c64..5c7e3e0e3 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
@@ -18,5 +18,5 @@ DEPENDS = "sdbusplus \
nlohmann-json"
S = "${WORKDIR}/git"
-inherit cmake systemd
+inherit cmake pkgconfig systemd
FILES:${PN} += "/usr/share/ipmbbridge/ipmb-channels.json"